550D & 3rd Battery Grip Issue

Issue #239 resolved
Adam created an issue

Had a few issues my own stupid fault left on my 3rd Party Battery Grip during the 1st part of the ML Install (enabling bootflag) I’m just so used to having it on there I forgot all about it. Now my camera only works when the grip is installed. I thought this would be ok though as I removed the Grip before I put in the bootable SDcard, but it wasn't.

Gone through ML de-install, reinstalled the latest canon firmware again over the ML version. The camera only works with battery grip no matter what firmware version I run or memory card/Battery/power supply configuration I use.
If I try and turn on the camera without the grip installed the camera is just dead.
If anyone has seen any links or other forum posts on a way of setting the cameras NVRAM back so I can use a battery or power supply in the camera I would appreciate any help.

Info on my current set up:
550D running Canon/ML firmware 1.0.9-ml-2010D
Battery Grip 3rd Party Meike : MK-550D

Thanks
Adam

Comments (9)

  1. Former user Account Deleted

    I actually have the exact same problem! I think part of the problem was that the warning is in step 2 of the install instructions when it should be in step 1... I only realized my mistake once I was already making the bootcard. :(

  2. Alex

    Does disable_bootflagf solve this? (see hidden settings in the user guide).

    The procedure should be similar as downgrading to 1.0.8.

    I'd try this:

    • make sure camera boots without ML (from a formatted card)
    • make sure camera is in the same config as when you've installed ML (with same grip, flash or whatever you had)
    • put this in magic.cfg:
     magic.disable_bootdiskf = 0 
    
    • start ML. It should boot and display:
    **disable_bootdiskf**
    
    • At next boot, ML should be gone and NVRAM should be restored.
    • make sure the camera works without ML (from a formatted card, again)
    • reinstall ML

    It may work or it may be worse... I didn't test it.

  3. Adam reporter

    Thanks for info a1ex, unfortunately seems like its worse :( After I received the disable_bootdiskf message the camera still will not work with out the battery grip installed, so it seems to have corrupted something within the camera.

    If anyone else has any ideas on how I can get my camera to work without having the battery grip installed I would be most grateful.

    Adam

  4. Former user Account Deleted

    I installed with a 3rd party grip/2 no name batteries and (just tested) works fine if I go back to using just 1 internal battery. Maybe we should track what grips cause this problem and what ones don't? Mine is a Meike MK-550d Multi-Power Battery Pack Got it from ebay.

  5. Alex

    Ouch. If it's worse... (I didn't understand well) what worked before and now does not work any more? Are you able to use the camera with grip, at least?

    Other users also suggested that resetting to default settings may be a good idea.

  6. Adam reporter

    I now feel the issue was caused when up dating the canon firmware which I did before the ML update. As it seems to make more sense to me that this would cause the issue and not ML.

    I did try reseting all the default setting but obviously all this achieves is reseting such items as pictures styles/tone priority setting etc it doesn't do a great deal.

    Nothing has changed since I stated the thread the camera still works but only when the grip is installed. (Worse as in the sense the problem must go deeper than just disabling ML)

    Thanks for all your help/input a1ex I will update as and when I find a fix for the issue,which I feel lies within the actual canon firmware update.

    At least from my experience I hope others wont make the same mistake of leaving any devices attached when they do any kind of updates to the camera including official canon firmware.

  7. Former user Account Deleted

    I stumbled across this and thought I had the same problem. I pulled off my grip, popped the battery in and nothing happened. I flashed 1.0.9 and tried again - still nothing. Then like a genius I put the smaller battery door on and realized there WAS a sensor on it.

    Simple, but had you tried it with the door on?

  8. Log in to comment