600D seems dead with a specific SDXC card

Issue #2413 resolved
Guto Pereira created an issue

Hello there, For almost a week I have been experiencing some trouble with my 600D when using my 64GB Kingston SDXC card... my camera seems dead if i don't use it with a autoexec.bin with it.

I used the steps on the forum to disable bootloader and uninstall magic lantern using another card after this started happening then formated the card.

If i turn on my camera without a card, it boots ok... If I turn on my camera with my 32BG SanDisk SDHC card, it boots ok... If I turn on my camera with my 64GB Kingston SDXC card, it doesn't boot at all... looks like there's not even a battery on it... When I perform a format without the "quick format" checkbox ticked on the PC(can't on the camera), I boots ok and looks normal... then stops after I take the battery off and put it on again of perform on camera format.

I suspect that my wife took off the card too soon and formatted the card after it would not open on the PC without uninstalling magic lantern(even though she said she didn't).

When I use the blink test from here it boots ok again!

Is there anything I could be missing?

thanks

sorry for any english mistakes, it's not my mother language.

Comments (5)

  1. Walter Schulz

    Unsupported. However there is a detailed installation instruction (PDF) included. Format card using FAT32 file system on your PC. Then use EOScard or MacBoot to make card bootable. EOScard will copy all files needed to card. Haven't used MacBoot. Maybe you have to copy extracted v2.3 files to card. Insert card into cam and startup. ML should work now without firmware update procedure (can't be used on cards with 64 GByte).

  2. Guto Pereira reporter

    I have tried that laready, but will again just in case...

    thanks for the prompt feedback

    edit:

    I did not boot...

    however, when I tried it again I forgot to copy the files to card after I performed a format from PC and made it bootable without any files... interestingly enough I looks like it is working!

    will leave camera aside without battery to test it later

    edit 2:

    It worked!

    I performed a low format on the card and it looks like it is working again without any support files

    thanks for the help!

    edit 3:

    stopped working again, will try it again

  3. Log in to comment