Issue #2484 new
Former user created an issue

Hello team. My camera doesn't work after updating/installing newer ML version magiclantern-Nightly.2016Feb27.5D2212 Update was successful. After update I tried to record video in LV mode and suddenly I saw an artifacts (green lines) on LCD screen. I stopped recording and pushed the button to do a shoot. But card led lighted up and didn't stop glowing for a long time not as usually for recording one photo. Camera was hanged. I turned it off, replaced battery and tried to turn on but the screen didn't light up. Symptoms: Camera LCD display doesn't turn on. Red LED doesn't blink when turning on power switch or closing battery and card doors. Small on top display works. I can see and change settings on the small display but sometimes camera hangs. EOS utility doesn't see camera.

Once when I turned on camera the card led blinked and the display lighted up. After turn off it didn't light up again. After an hours of investigating and tries I have found the method how to light up display. After reinstalling battery and a tenth of opening and closing the battery door the card led blinks and display lights up. When display is working Eos utility can see camera. But when I push the button to do a shoot, mirror lifts up, red led doesn't stop to glow and camera hangs. Only battery reinstalling can help to turn off camera. And again from the beginning tenth of tries etc... I tried to update with Canon firmware but camera says that there is no firmware on card was found and hangs. Tried to update from EOS utility and after downloading .fir file from the PC it says something about press SET button on camera, but camera hangs with error no firmware file found. Sometimes it shows me ERR70 on small screen. Once there was ERR80.
When display is working I can navigate through MENU, can format a card, can see a firmware version (original canon firmware) but LV doesnt work. Autofocus works. Even when display didn't turn on. But sometimes not.
Tried with ML card (latest builds, old builds), empty card, without card. Without card there is no notification on small display "NO CF Card". With empty card. Cards were formatted. No boot flag and ML files on card. Tried to put diagnostic autoexec.bin but camera didn't detect card with power switch is in OFF. Only once from 20-30+ battery door opening-closing Led was blinked but nothing happend. The only one error in log (see attachment). I was using older version of ML and for a couple of month and there were no problems.

If you need additional information please ask I will try provide it. I am very disappointed. Please help.
Thank you

Comments (12)

  1. Alex

    Sounds like a hardware issue to me.

    To update Canon firmware, you should format the card from the camera, then place the FIR on the root of the card (otherwise it won't be recognized).

    I can check the ROM, and also get a log file while taking a test picture, but I don't have high hopes for this case. Sorry.

  2. Den

    I tried to connect external monitor via AV out. It works when main display works. I did a few photos before it was hanged. Photo in attachment.

  3. Alex

    Other than I've already mentioned, not really. In particular, the inconsistent behavior and the artifacts on the image could suggest a hardware issue.

    Are you sure you have prepared the card correctly for the firmware update? This would be the first case of a camera not accepting a Canon firmware update from a card formatted from the camera (besides all those user errors on the forum). If in doubt, finding a friend with a 5D2 can be helpful, just to make sure the card is prepared correctly.

    After you format a card, place ML on it, start the camera and leave it on for about 1 minute, do you get some files named ROM*.BIN under ML/LOGS on the card? Can you send me those files?

  4. Den

    I updated camera firmware with Canon firmware on my old 400D. I installed CHDK on my old 400D and it works without any issues for years. I updated camera firmware with Canon firmware to latest one on 5DMII. I installed ML a few month ago and all was fine. Only after last update of ML something went wrong. So I prepared cards for this purposes not once.

    Want to clarify. "After you format a card...." Do you mean simply format card in camera and copy unzipped ML files or make card bootable and put unzipped files? Regarding ROM files. I have ROM files from my very first installation of ML. And I have ROM files after update.

    I tried to prepare card for ML with EOS Card utility as well.

    It seems the problem that camera not checking the card when starting. Or can't detect or something like this. There is even no number of photos in the corner on top display (counter). Only in 1 from 10-15... tries the card Led blinks and display start working, and I can use Menu etc.. Also sometimes I can do a few photos. When I try to turn on LV it shows me ERR70. One more thing. In one of that happy moments when camera turned on I did a shoot in RAW and it looks like normal and without artifacts. Only jpg format looks defected.
    Thank you.

  5. Den

    I have tried to put mentioned autoexec.bin to the card but nothing happened. Display didn't light up. Maybe I need some special boot loader for 5DMII? Or something else? I don't remember exactly what features I was using. I was recording video and something went wrong. I also tried to do a shoots during video recording. Please take a look what happened during video recording. https://drive.google.com/folderview?id=0B5hHa4vCSLV_TUdQWUxBd3JsbWc&usp=sharing Also the shoots was defected. DNG format and strange size.

  6. Alex

    You need to make your card bootable (just like with any other ML card). The easiest way is to replace autoexec.bin on a card with ML already on it.

    In the link, you enabled silent pictures. They are not meant to work during recording, and I never tried to use them this way.

  7. Den

    Hello A1ex. Is it enough to make card bootable with EOScard tool and put ML files on it? And after that replace autoexec.bin on the card? Did you see a video as well and that sudden green noise on in the end? The problem is that I can't turn on both camera and main display when I switching power switch from "OFF" to "ON". Only small display works and it seems it doesn't check card because Led not blinks. But I can time to time turn on both camera and display by plenty of opening/closing battery door when the power switch is in "ON" state. In this case led blinks and camera and main display turns on. Thank you

  8. Alex

    Did you manage to run the display test? For that, you only need card bootable and autoexec.bin (no other files are used).

  9. Log in to comment