error "unexpected symbol" after loading modules

Issue #2496 resolved
Former user created an issue

install went ok

then got this error after loading modules

this error screen covers live view and menu screens

thanks!

Comments (11)

  1. Alex

    Does it help if you format the card and copy ML again?

    P.S. only load the modules you actually want to use.

  2. David Milligan

    Stupid freakin Mac OSX Finder. Maybe we should disable scripts that start with "_" for this reason. Would also be a handy way to manually enable/disable scripts when you're out and about.

  3. Alex

    Ha, didn't notice the underscore. Right, I don't see any reason for scripts to start with _.

    Also I like the idea of manually enabling/disabling scripts (maybe a submenu to list all of them, in a way similar to modules tab)?

  4. Jack Spade

    ~I started thread above before I had an account.~

    Yes, I tried reformatting the card, downloading fresh ML files, repartitioning and then reformatting card.

    Yes, I also tried not using dual_iso module to test as well (although I would like to use that) and it still showed the dual_iso error

    any thoughts on how to fix?

    Thanks!

  5. Jack Spade

    I took a clue from dmilligin about OS X finder and removed .DS_Store hidden file. I don't know if that helped or not... then I loaded each module one by one.

    They all worked except for lua.mo which caused the same error to show, but I was able to disable lua.mo

    If this is not needed for ML to run, I'm not too fussed about it as I wouldn't know what to do with it anyway.

    Should I just leave it as it is...or will this cause problems?

    Thanks again!!!

  6. David Milligan

    It's actually another more hidden file. The Mac finder creates a file starting with "._" for EVERY single file it finds. This gets turned into just _ when it's converted to a FAT32 8.3 filename. Lua already ignores files that start with a dot ".", but the dot gets lost in the 8.3 conversion (it's in the LFN though).

    As already stated, if you don't know what the module does then don't load it.

  7. Alex

    What dual_iso error are you talking about? I thought the issue is about Lua.

    None of the modules are needed for ML to run; they are designed to be loaded only if you want the extra functionality.

  8. Jack Spade

    Now, all modules working except lua.mo (which I don't use)

    (Dual pixel was not working at first, but now works.)

    So, if no other problems develop. All OK.

  9. Log in to comment