70D: Black screen menu

Issue #2535 resolved
Dave created an issue

I was using the latest release of the firmware but I have some issues with it and so I didn't feel it was stable enough, had a weird bug where I was viewing a image and it went static and disappeared then froze so I had to remove the battery. I then went and formatted the card on my PC and when I put the card back in the camera and pressed the menu button I just get a black screen and have to take the battery out etc. Everything else work though. Sometimes I get err 70 on the lcd but not always and err 70 seems unrelated to this issue.

Not sure what if anything I can do.

Comments (51)

  1. Alex

    Do you have the issue even after starting the camera without a ML card?

    Can you clear Canon settings somehow, or you just can't get in the menu at all?

  2. Dave reporter

    I haven't tried with an ML card yet, I did think about it but didn't want to try anything until someone who knew what they were talking about told me too.

    I cannot get to it at all as of yet. May be ML card will work but I feel as though it won't, should I try with one?

  3. Dave reporter

    Tried with ML card but same issue.

    Seems I have just broken by canon menu somehow. Didn't think I had done anything different. I now can't access ML either.

  4. Dave reporter

    Unfortunately I didn't make a backup of the ROM files.

    All of Canon stock firmware functions work so all the buttons do what they should except for the menu button.

    As I had formatted the card on my computer I can't use ML any more so I don't think I can run the tests. I guess the boot flag will still be enable??? I lack knowledge.

    I can make a video if it's easier for you to visualise?

  5. Alex

    The bootflag is still enabled, just make the card bootable.

    Which Canon stock firmware functions did you try?

  6. Dave reporter

    All of them pretty much. Everything seems to work as it should. I think that the menu button has been reassigned to nothing so it just bricks itself.

  7. Dave reporter

    I can't do that because I can run ML any more.

    I'll make a video although I think I am beyond hope. Sorry if I am messing you about.

  8. Dave reporter

    Folder is empty :(

    I don't get a lot of flashing so it can't be reading ML to the card or writing to.

  9. Dave reporter

    The card has the auto.exec and .fir file but has been formatted since ML was last running.

    If thats not what you mean I think I still have access to other 70Ds but I think they are ML versions b not a if I need to make a another bootable card for mine.

  10. nikfreak

    late to the party but let's start / do this. If you are on windows download EOSCARD and enable the "EOS_DEVELOP"as well as "BOOTDISK" checkboxes and click save. Your card is now bootable again and you can extract latest 70D ML build again onto it.

    Afterwards as instructed take a backup from ROM0/1.BIN and tell us how far you got (e.g. ML menu is accesible again etc...). If in doubt post again a video

  11. Dave reporter

    Made it bootable but ML crashed when I tried to run it but did get the ROMs.

    Getting somewhere now, thanks for putting up with me so far.

  12. nikfreak

    ROMs aren't meant to be made public. Remove your link now again.

    How far did it go before it crashed. You need to be more specific / detailed in your answers plz. Did ML place any log files onto your sdcard (crash.log). Did you try to start your camera from Tv, Avmodes. Try all of 'em one by one starting with the "C mode" to check if you can access / bypass to canon menu.

  13. Dave reporter

    Turned the camera on (in M mode) pressed trash can and crashed straight away, got a few shades of black.

    Got one crash log: ASSERT: strcmp( pHeader->Name, pcsCommonName ) == 0 at ./ResLoad/ResLoad.c:43, task CtrlSrv lv:0 mode:3

    Magic Lantern version : Nightly.2016Apr23.70D111A Mercurial changeset : 591ba5bf7c75 (70D-merge) tip Built on 2016-04-23 19:23:06 UTC by ml@ml-VirtualBox. Free Memory : 228K + 1907K

    When starting in different modes do you mean trying to open the ML menu?

  14. nikfreak

    No there's a rounded mode dial on topleft of your camera body printing M, Tv, Av , C etc. Turn camera off. dial it to C mode and turn the cam on. That's what I want you to do. Try all of them starting with "C mode" and try to bypass the error that way. Can you access Canon menu or still get a crash?

    EDIT: If all fails then did you already extract the "ICEMAN" release Alpha7b onto your sdcard and tried that one?

    We might continue with a special release from dmspy-experiments branch to intercept startup messages.

  15. Alex

    @nikfreak: I'm thinking to get the 70D GUI running in QEMU, so we can reproduce the error there.

    I need a dm-spy log from you, with the following configuration:

    • CONFIG_DEBUG_INTERCEPT_STARTUP=y
    • mpu_send/mpu_recv stubs in dm-spy-extra.c
    • the log should cover the camera startup and also entering Canon menu
    • the startup log is limited to 64K, which is not enough for this; you will want to increase it (for example, place it in IVA_NVY, e.g. static char * staticbuf = 0x15000000, and define BUF_SIZE as 1MB).

    I'll probably need additional logs after that, we'll see.

  16. Dave reporter

    Crashes the same in all modes.

    Took a picture and in the 2sec playback it showed some ML features such spot meter. "Raw error, falling back to YUV overlays" with a histogram.

    I have ran "ICEMAN" in the past but don't have that release on me to try with. NVM its on the thread do you need me to try it?

  17. nikfreak

    Hmm I placed StateTransition, mpu_send/recv into dm-spy-extra (compared with 5d123). Will give it another go in the evening after work.

  18. Alex

    There are two sections - one for startup, another for experiments done after startup. On 5D3_123, mpu_send/recv are defined in the first one, but StateTransition is in the second one.

    If in doubt, add a small typo that would cause a compilation error, to make sure the code you are editing actually gets compiled.

  19. nikfreak

    nope, this is what I put right at start into ifdef CONIG_DEBUG_INTERCEPT_STARTUP:

    #ifdef CONFIG_70D
        { 0x3dd24,    "TryPostEvent", 5 },
        { 0xFFD84BD4, "mpu_send", 2, mpu_send_log },
        { 0xffd513e8, "mpu_recv", 1, mpu_recv_log},
    #endif
    

    and the result is the same. My brain also made a mistake yesterday while writing "StateTransition". It was "TryPostEvent". Sorry for the confusion. I am now going to try it again and create a new branch from your dm-spy-experiments and merge 70D into it.

  20. nikfreak

    something like this in dm.log is ok for you?

    **INTERRUP:00c5c360:00:00: *** mpu_recv(06 05 01 97 00 01), from 3986c
    
       PropMgr:00c5c318:00:00: *** mpu_send(08 06 00 00 01 97 00), from 616c
    
  21. Alex

    Yes, I made major progress in the last two weeks (will commit soon), but still need some help from @nikfreak (will ask by PM).

  22. Dave reporter

    Hi, Its been a couple of months now and I was wondering if you were still working on this, hit a wall with it and there's nothing you can do at the moment or simply forgot and had better things to do?. All of which though are fine.

  23. Alex

    I'd say you could try it, although I don't really expect the upgrade to fix the issue. But I don't expect it to break anything either.

    Anyway, as long as you have a copy of the old ROM, it's unlikely to cause any unrecoverable damage.

  24. nikfreak

    Dave what's your status about 1.1.2 firmware? can you use EOSUtility to update your firmware via PC?

  25. Dave reporter

    So it turns out there was a lot of point in updating the firmware! I can now open the menu without it crashing.

    I haven't tested with a lens or ML yet but I presume it will work. Will get back to you if it doesn't.

    Thank you for all the help.

  26. Log in to comment