5d Mark II - stoped working

Issue #2563 resolved
Former user created an issue

Hi there,

I have a 3 year old 5d mark II with magiclantern installed for around 1,5 year. It has been working without issues til few week ago.

I had the LiveView on and I noticed the battery was blinking so I decided to change it for a new one. Camera didn't switch one that day after the change.

Few days later it switched on perfectly but when I changed the memory card, it stopped working turn again.

Unfortunately I didn't re-start battery each time I was changing the card since I was aware this was a best practice.

Camera doesn't turn on without card.

Please advice.

Comments (5)

  1. Alex

    "Unfortunately I didn't re-start battery each time I was changing the card since I was aware this was a best practice." => it's a step required for troubleshooting, but you don't need to do that during regular usage.

    But if it doesn't start at all, the basic troubleshooting sequence is taking the battery out, then starting the camera without a card. Just removing the card and turning the power switch off and back on will not do the trick, as the power switch is just a soft button.

    If it doesn't work without a card, try the display test: http://www.magiclantern.fm/forum/index.php?topic=14732.0

    If it still doesn't work, try the LED blinking test: http://magiclantern.fm/forum/index.php?topic=2296.0

    If there's no sign of life, it's most likely a hardware issue.

  2. Francisco

    Hi Alex,

    Thanks for your prompt answer. I followed your instructions and I can switch on the camera now. Great news! However, when I introduce the two memory cards where I had magic lantern installed ( I recently erase it from the cards), camera stops workings. But it doesnt happen with my third memory card which didnt have magic lantern. Can you guide me here? What are the next steps to be followed? reset the camera settings? thanks for your help

  3. Walter Schulz

    Delete autoexec.bin and ML directory from card root directories. Copy extracted nightly build contents to card. Retry and report back.

  4. Francisco

    I just tested it and it works fine again, My question now is if these cards will work without th nightly build files

  5. Log in to comment