canon 600d doesn't turn on after sd card with ml files has been lost

Issue #2575 resolved
Former user created an issue

Hi guys. I need you help. I had a fully working 600d with an old ml installed. Unfortunatelly someone took out my sd card and in a way or another damaged it. I tried to format it but it didn't work. Now my camera is turning on without an sd crd but when i inserted a card, the camera will not turn on anymore. I have to eject the battery and thean the camera will start again without card. I tried: 1.To put into camera a fresh formatted card in computer fat not fat32 not working. 2. I repeted the first step and then downloaded the last ml version and tried to move on sd the folder with ml files, the autoexec and the other file. Not working 3. I tried step1,2(without autoexec) and used eos card utility with both option chkdsk and ml. Not working.

Any sugestion will be very welcomed. best regards

Comments (9)

  1. Walter Schulz
    • Format card in cardreader with FAT32 file system.
    • Run EOScard utility and make card bootable
    • Delete all content from card.
    • Copy diagnostic autoexec.bin to card. http://www.magiclantern.fm/forum/index.php?topic=2296.0 first link.
    • Turn cam off. Remove card (if any) and battery. Insert card with diagnostic autoexec.bin into cam and close compartment doors. Do not turn on cam.

    Do you get a screenmessage?

  2. Butros

    Thanks. I will do what you told me and i will be back with what i've done. But i have two questions: In eos card utility which option should i use? Only the chdsk opyion or/and ml opyion? Or i just check the botable radio button. And second question cardreader means and external card reader or can i use the notebook built in one?

  3. Butros

    Results: First of all formatted a 2gb card in fat32 version, maked bootable with chkdsk option and added autoexec.bin file from first link. DIndn't work. No message on the screen. Tried also with fat16 version. Not working. tried also with the second autoexec.bin link (blink test). not working. If i remove the card and the battery and then insert it back the camera turns on without any problem.

  4. Butros

    i used it . In the EOScard there are two options. I choosed chdk option (sorry for writing wrong chkdsk instead of chdk)

  5. Cameron Marks

    I am having a very similar issue with my 7D. It only works when the card is not in the camera. As soon as I put any card in the camera with or without ML/BootFlag/Autoexec.bin, etc nothing happens. The only sign of life I get with a card in the camera is the battery light on the front of the camera flashes once when a battery is inserted. Any thoughts?

  6. Log in to comment