7D wont Boot

Issue #2597 closed
Cameron Marks created an issue

I had ML on my 7D, hadn't used my camera in a while tried to turn it on last night and nothing happens. The camera turns on without the SD card in it, but as soon as I put the SD card in it, it no longer turns on. No lights, no autofocus. Tried to reformat the card on my computer, and on old Canon T3 but had no luck.

Comments (6)

  1. Cameron Marks reporter

    One thing I have noticed (maybe something I just have never noticed before though) When I have the camera switched on with the SD card in but it is not doing anything: I can turn the camera off, take the battery out and then when I put the battery back in a light flashes yellow on the front of the camera.

  2. Cameron Marks reporter

    Thanks for responding Nikfreak so you posted twice about my issue because I posted this a couple places trying to get it fixed. So I checked the pins and they are all straight, so I bought a CF card, put it in, and everything seems to work flawlessly. Without me going out and investing in a bunch of old memory cards, what do you think could be causing my SD cards to not work? I use an SD to CF adapter and my computer has no problems with the adapter, so I wouldn't think it would be that. But I have 6 SD cards I have tried with no luck.. Any further suggestions? Thanks again!

  3. nikfreak

    it's either the adapter or something to do with your computer. I'd first try all steps again on another computer.

  4. Alex

    ML used to work with the adapter?

    If the card is prepared correctly, I'm not sure how to diagnose it. There is a serial port inside the camera, but I don't know the pinout; if you can identify it and see those messages, it might give a hint.

    Otherwise, I'm afraid I have no way to diagnose it.

  5. nikfreak

    Author doesn't respond. Answer from 2016-09-02 indicates that CF cards tend to work but sdcards with his CF adapter don't. Quite sure it was the adapter.

  6. Log in to comment