T2i only functions when connected via USB

Issue #2787 new
Anonymous created an issue

I just bought this camera used last week, its in perfect condition. I took 2000 pictures over the weekend, and since my macbook pro can't read 64g memory cards, I connected my camera via USB cable for the data transfer. Now my camera wont function unless it's connected via USB, and the view finder reads busy when its disconnected. I've tried resetting all the camera settings, I've tried multiple memory cards, I got a new USB cable from the camera store, I tried installing Magic Lantern, which surprisingly helped, but not enough. With ML installed, my camera will 'operate' when not plugged into USB, but is says headphones are installed and reads 'busy'. Won't release the shutter except through EOS utility 2. I'm reaching my wits end, I would just absolutely HATE to have to take this to a professional and pay to have them disassemble my Rebel to fix what is obviously a simple technical hangup. Any help beyond the obvious would be much appreciated. Please don't ask me if I've tried a new card, new cable, clearing settings, reformatting card, because none of these simple solutions are solving my problem. Thanks a ton!

Comments (1)

  1. Alex

    Are you able to compile ML? Would be easier to debug that way.

    First test: the dm-spy-experiments branch (unfortunately it doesn't compile out of the box on 550D). Will fix it later.

  2. Log in to comment