Issue #2821 resolved
Elko
created an issue

I was trying some options for videos and then the display shows me only green channel instead complete rgb and some seconds later turns completely green (solid green). So I tried (several times but with same results) to reboot the camera and the display returns solid green disabling me to take control of the camera (even for the simple canon firmware menu). How can I reset or format or do something without see nothing except solid green?

Thanks.

Comments (9)

  1. Elko reporter

    I prefer to asnwer step by step.

    Removing card: All normal. Just like fabric. (As you can see in this other pic) InShot_20171213_162018168[1].jpg

    Portable display test: What's the procedure with ML already into the SD? Do I have to replace the autoexec.bin of this "not working version" of ML from the same sd? Is it valid for this 1200d?

    Another thing that I forgot to mention is that when this issue started to act I was using a "Viltrox DC-70 II" through hdmi.

  2. Alex

    Yes, replace autoexec.bin. However, since it already started well:

    • backup your old ML directory (to look under ML/SETTINGS for settings that might cause the issue)
    • delete (or rename) the ML/SETTINGS directory
    • restore your old settings one by one, until you find the one that caused the issue.

    If that doesn't work, just format the card and reinstall ML from scratch. Make sure you can reproduce the issue though (no 1200D here, so I have no other way to fix it).

  3. Elko reporter

    Catch it! I renamed the folder and rebooted without problems. Then I did the same thing that caused the issue just as you said right above. And I found it in Display>Advanced settings>Color scheme. After that the screen became solid red (this time) without letting me to change status or go back because the display stucked in red, PicsArt_12-13-07.12.04[1].jpg

    Is there a fix around?

  4. Alex

    Works fine in QEMU.

    Notice that ML menu icons (which also use custom color palette entries) have correct color.

    Can you also try other features that depend on custom color palette entries? These are:

    • Display -> Clear Overlays. These work by making the entire palette transparent (thus clearing everything), then restoring the old palette to bring back the overlays.
    • Fast zebras in LiveView (enabled by default, e.g. on fresh ML install)

    Are these two working fine?

    Are you able to compile ML?

    If yes: does it help if you play around in tweaks.c, alter_bitmap_palette? The first thing to try would be to reduce the range in the for loop (try smaller intervals, e.g. 0-10, 10-20 and so on, maybe one of these color entries is causing the issue). If it still doesn't help: make sure the display looks fine if you delete the body of that for loop, then continue with the trial and error.

    If not: other 1200D owner should be able to look into this (it's a very easy coding task, but requires the camera in one's hands, as the issue seems hardware-specific and may require some 10-100 test runs to narrow it down).

  5. Elko reporter

    I had no probs with those two options. Everything was fine. But I'm not able to compile ML, cause I haven't got the competence at all. I'm sorry for that.

    Hope somebody will fix that issue soon though. Thank you Alex by the way!

  6. alessandro profiti

    I had the same issues on 50D, to solve you have to select (with some trials) Color Scheme back to default or delete configuration files (magic.cfg and menus.cfg).

    It's present in lua_fix and manual_lens branches, but no issues in latest nightly (2017-12-07). So maybe can be related to some commits from lua_fix?

  7. Log in to comment