SD Locked in Read Only /Write-Protected

Issue #2884 new
Former user created an issue

My SD card is locked in write protected. I tried through windows command prompt and other tools to change attributes with no luck. I will attempt to attach the files from the SD card. I can only attach one file so I'm going to take a wild guess on which one is best

Comments (9)

  1. Walter Schulz

    In which way is this ML related?

    Do you have tried different cards? Are all of them unable to store pics or is this a singulary issue with this card? Does write-protection occur on cam only?

    Flash devices going mad is happening without rhyme or reason. I suppose you already tried diskpart according to https://www.techadvisor.co.uk/how-to/storage/remove-write-protection-usb-3633096/

    Maybe a1ex can do his magic restoring your card but this looks like an "invalid" issue, too.

  2. Katy Snodgrass

    I have not tried different cards for fear of locking those as well. I've tried diskpart with no luck. I've also tried various software with no luck. It's completely locked so I cant use it in my camera, if I do it freezes camera. I'm thinking its one of those going mad times but wanted to share if so maybe it will help improve builds.

  3. Alex

    If it happens in the camera AND in the card reader, it's likely the card. Try another card. Also try this card in another card reader, if possible.

    This error is usually caused by the read-only microswitch being defective. I can easily patch this one, but I find it unlikely to trigger the error in both the camera and the card reader.

    I'm not sure whether other initialization errors on the card side could give the same error. I could get a debug log displayed on the screen, but it's not just flipping a switch (need to add some scrolling capability, as the log is going to be very large). First try another card and report back.

  4. Log in to comment