EOS M: ML works on SanDisk Ultra 128 SDXC but not PNY Elite 32GB SDHC

Issue #2896 invalid
Anonymous created an issue

Hi all,

I am new here. I just started using ML on my EOS M. I got it working no problem on my SanDisk 128GB SDXC. I simply needed to format the sd card, copy the files, update firmware inside the camera and everything worked as expected.

I shoot in RAW so 128GB isn't enough space. So recently I purchased 2 PNY Elite 32GB SDHC cards for extra storage. The camera was able to read the card. I tried to repeat the process (format, copy & paste, update) but I wasn't able to get ML working on them. When updating firmware it says

"Autoexec.bin not found. Please copy all ML files."

I know for sure that the issue is not due to me "misplacing" of the Autoexec.bin file. The Autoexec.bin is clearly in the root directory of the PNY card.

I then tried using the EOScard.exe. I formatted the PNY card. Then I selected EOS_Develop and Bootdisk options. Finally I copied and pasted the ML-SETUP.FIR file over to the root of the PNY card. So once again everything is in order. This time when I turn on the camera, it just keep flashing the green "loading" light. At this point even if I put back my working SanDisk card in there, it won't work. The only way to fix it is to take out the battery.

Another thing I tried with EOScard.exe is to only select EOS_Develop and not the Bootdisk. The camera would be able to once again read the PNY card, but no ML is loaded. When I tried to update this time I got a slightly different error:

"FONTS directory not found! Please copy all ML files."

The above situation happens for both the PNY cards I got.

I am not sure where this error is coming from. The Camera has no problem reading the PNY card. And my PC and Android phone has no problem reading the card. But when trying to update the firmware, it seems suddenly the camera is no longer able to read the PNY to locate the necessary files.

Once again I got ML working with my SanDisk SDXC card. I wonder if the problem is due to the PNY being SDHC cards. Perhaps the different systemS messed it up?

I would appreciate any help you can give me. Thanks in advance! =)

Comments (5)

  1. Alex

    To diagnose this, you may run the camera firmware in QEMU directly from the bad card. However, I'm afraid it may be hard to do this under Windows.

    https://bitbucket.org/hudson/magic-lantern/src/qemu/contrib/qemu/README.rst#rst-header-running-from-the-physical-sd-cf-card

    Otherwise, a screenshot showing the card contents may help. Also try formatting the card from the camera before copying ML files on it.

    If you are running Windows, also try the following command in a CMD prompt (assuming your SD card drive is F:):

    F:
    dir /x
    
  2. Eric Chan

    Hi Alex. OP here. Thanks for your comment. I did format the card from the camera itself before copying the ML files onto it. So I don't think that is the problem.

    Here is a copy and paste from CMD dir/x. The ML folder, autoexec.bin and ML-SETUP.FIR are all at the root directory of the SD card.

    Microsoft Windows [Version 6.1.7600] Copyright (c) 2009 Microsoft Corporation. All rights reserved.

    C:\Users\CHIPS>J:

    J:>dir /x Volume in drive J is EOS_DIGITAL Volume Serial Number is 1380-0C4D

    Directory of J:\

    2018-07-28 12:39 PM <DIR> DCIM 2018-07-28 12:39 PM <DIR> MISC 2012-07-23 07:08 PM 158,094 INSTALL.pdf 2018-07-28 01:23 PM <DIR> ML 2012-07-23 07:08 PM 1,229,049 USERGU~1.PDF UserGuide.pdf 2012-07-23 07:08 PM 1,675,268 autoexec.bin 2018-07-02 03:07 PM 65,820 ML-SETUP.FIR 4 File(s) 3,128,231 bytes 3 Dir(s) 31,265,947,648 bytes free

    J:>

  3. Eric Chan

    Ok it works now! I formatted the PNY card again and copied the files from the website into it. I think the difference is that I copied the files from my working SanDisk card over to the PNY card directly, instead of doing a fresh install from the original files.

    Thanks Alex for your help! =)

    Some notes for those that comes after me:

    1) When installing do not just copy and paste the files from the working old (SanDisk) card to the new (PNY) card, which are 30MB in size. Be sure to do a fresh install from the original files directly from the website that is 3MB in size.

    2) Be careful when using EOScard.exe. The autoexec.bin file in it might be outdated (year 2012). Use the latest one.

  4. Log in to comment