Touchscreen becomes unresponsive after erasing any image until gallery is exited

Issue #2901 resolved
Former user created an issue

The touchscreen becomes unresponsive after deleting any image. It becomes operational again after exiting the viewer via the "play" button. Confirmed issue not present with ML not loaded.

Comments (32)

  1. Patrick Jane

    Hi Alex, I found the problem on both the magiclantern-Nightly.2018Jul03.700D115 as well as magiclantern-lua_fix.2018Mar31.700D115. As for the settings I reset the ML as well as camera settings and found the issue to persist.

    With the magiclantern-lua_fix.2018Mar31.700D115 in addition to the above issue I also found that upon powering on the camera and accessing either the screen brightness settings or background display setting (the primary screen with all the settings that shows up on power on) the graphic/image would not show up, subsequently accessing play mode the images would display in a little rectangle on the bottom left. I know this is beyond what this bug report is about. I would create another ticket if it is required.

    Thank you for the quick follow up!

  2. Alex

    Confirmed. Seems to be caused by calling redraw() to erase the message printed by ML when pressing SET.

    Only the playback dialog seems to be affected; other dialogs (menu, LiveView, info screen) seem to work fine after redrawing.

    Other models affected? (650D, 70D, 100D, EOSM)

    Screen brightness and screen color dialogs are working fine with the lua_fix build; not sure how to reproduce these.

  3. Patrick Jane

    Can confirm, with lua fix there’s no screen color graphics or image display on screen brightness display until I’ve first entered an exited play mode. Reset ML as well as camera settings to test.

  4. Patrick Jane

    It seems the play mode displaying pics scattered in the corners issue in lua fix seems to occur after accessing any second level option in the main camera settings (AEB, image size, etc.) until play mode is entered and exited once.

  5. Patrick Jane

    700d - Copy.jpg

    You can see the image only appears behind the drawn elements in the ui. This bug is NOT present in the nightly.

  6. Alex

    The dialog_redraw function also appears to block the LCD sensor events.

    It's not easy to find a clean fix that would cover all these cases :(

  7. Patrick Jane

    Oh well at least there is a workaround for the touchscreen issue (and possibly the lcd sensor events) by disabling the image review setting for the set plus dial combination.

    I might have come across another issue with lua fix tho... if we require set button to be pressed in order to load ml and load a card without ml (and not bootable), the read write led keeps on blinking erratically. I was too afraid to recreate the issue though and the issue only went away i think after i reset ml to defaults.

  8. Alex

    If the card is not bootable, all that runs is vanilla Canon firmware. The bootloader checks the card contents at startup, which may result in the boot process being slower by a small amount (depending on card speed/size). Whatever happens after the main firmware starts is no longer affected by ML.

    I've seen similar LED blinking happening on 60D some years ago - formatting the card should fix it. If you find a way to reproduce, we can run Canon firmware in QEMU with the "buggy" physical card to see what exactly it does, though it's likely harmless.

    If you require SET at startup in order to load ML, and the card is bootable, ML attempts to do a fade out effect on the LED. That effect appears to work properly on 700D.

  9. Daniel

    I can confirm that the touchscreen being unresponsive when being in play mode is a frequent issue for me, too. My workaround, for the time being, is to press the trash button, go arrow left and then set (with other words: chose "cancel"), then the touchscreen works again.

  10. Alex

    Just to make sure it won't get overlooked:

    Are other models affected by this issue? (650D, 70D, 100D, EOSM)

  11. Patrick Jane

    @Alex i think the blinking led happened with the card whether or not it had ml and was bootable. I believe it occurred with switching on the camera without a card (contrary to what i wrote earlier, sorry) inside with hold set to load ml option set to on. I will test it again and post back.

    I had panicked back then and just took out the battery after the issue continued to happen.

  12. Alex

    Giving up; committed the workarounds.

    There was no feedback from other touch-screen models, but I've assumed they are also affected.

  13. Alex

    Apparently EOS M was not affected; tested by @ccritix.

    Test code:

    static void run_test()
        bmp_printf(FONT_MED, 50, 50, "now check touchscreen");

    700D: touch screen stops after running this.

    EOS M: touch screen still working.

    Please check 650D, 100D, 70D and EOSM2.

    cc @WalterSchulz, @daniel_fort, @Dannephoto, @nikfreak, @es_as

  14. Daniel Fort

    Just out of curiosity I ran that code on the 700D and EOSM with the current unified branch and it didn't freeze up the touch screen on either camera. Maybe there's more to it than running "don't click me" ? Does the camera need to be in playback mode and you need to erase a file to trigger this bug?

  15. Alex

    Hm, I've tested this myself a some weeks ago on 700D. You need to have one or more images on the card; after redrawing, the touch screen operation stopped and had to switch GUI modes (i.e. exit playback mode and enter again) in order to resume it.

    To reproduce on 700D with default configuration, vanilla builds:

    • start camera in photo mode
    • press PLAY
    • drag or zoom the image with your finger(s), as you would do on a smartphone (this will work)
    • press SET, notice the "Scrollwheel" message at the bottom of the screen
    • release SET, the "Scrollwheel" message disappears (this triggers a redraw)
    • try to drag or zoom again; it will no longer work
  16. Walter Schulz

    My 650D is running dfort's build 2018.Jul04 for firmware 1.0.5. Error is reproduceable with this build, too.

    I'm on the road but able to switch back to main 1.0.4 nightly if necessary.

  17. Alex

    Alright, so far 650D and 700D are affected, but EOSM appears to be clean. @Licaon_Kter or @Dannephoto, second opinion?

  18. danne

    Probably missing a step here but how do I test this properly? Right now I downloaded latest nightly build version for eosm and previewing and zooming into the image and then pressing SET will get me this: Screen Shot 2018-09-17 at 14.06.34.png_300px.jpg

    What build could I use for testing purposes? Above was eosm but I want to check my 100D as well.

  19. Alex

    The EOS M doesn't have the play mode actions enabled (FEATURE_SET_MAINDIAL, comment "Set taken over by Q"), so you won't be able to reproduce it by pressing SET. Try the run_test code instead.

    100D seems to have it enabled, but its SET button has the same issue as on EOS M. Does it (SET + MainDial) even work? Unable to test in QEMU yet.

  20. nikfreak

    due to the combined q/set button I implemented "AV"+"Scrollwheel" buttons for the 100D - and that combination of "AV" and "Scrollwheel" works. For the issue I can confirm that following your instructions above after releasing "AV" + "Scrollwheel" trying to drag or zoom again; it will no longer work

  21. Daniel Fort

    Re-tested EOSM and it is affected. Make sure you have one or more images saved on the card.

    • start camera in photo mode
    • run the "Don't click me!" code
    • the code will put the camera into PLAY mode and print "now check touchscreen"
    • drag or zoom the image with your finger(s), as you would do on a smartphone (this will not work after running the test code)

    If you're quick enough or increase msleep to a larger value you'll be able to drag or zoom the image until the test code kicks in and then the touchscreen will freeze.

    Also re-tested the 700D and reproduced the bug.

  22. Patrick Jane

    Thanks for you work guys but how exactly do I run the build with the fixes in place that I pointed out in this report?

  23. Log in to comment