550d display off, af on with card / works fine without card

Issue #2918 invalid
Piotr Deszkiewicz created an issue

Hi,
I just took my old 550d out of the drawer wanting to sell it. Unfortunately I do not have a boot card any longer. Without a card the camera seems to work completely fine, I can access the menu, make use of all the functions and take pictures. But with an SD card (blank) inserted the screen goes and stays off and I can only use AF without taking pictures. I suspected that the problem is not having a bootable card so I tried to prepare one. Still nothing. Can you please help?
Best,
PD

Comments (18)

  1. Walter Schulz

    User error.
    Format card (no SDXC, no WiFi) using cardreader.
    Remove battery.
    Insert card.
    Insert battery.
    If cam boots up: Redo installation and follow on-screen instruction to deinstall Magic Lantern.

  2. Piotr Deszkiewicz reporter

    Hi Walter, I just did exactly as told - still nothing, black screen and functioning AF/flash with formatted SDHC card vs. fully functional camera without card. I'm wondering - I can't find my battery charger so I'm using AC adapter. Maybe this is the issue?

  3. Walter Schulz

    Kowalski's analysis offers several explanations:
    1) The card you are using is causing the problem.
    2) The cam's card slot is defective.
    3) The cam is wacky.
    4) You are doing it wrong.

    Is there another ML enabled cam around? Insert card there and tell us what happens.

  4. Piotr Deszkiewicz reporter

    I just tried with a different card following exactly your instructions, so either the cam is wacky or there's something wrong with the slot...

  5. Piotr Deszkiewicz reporter

    To be honest, I don't think there's some issue with the card slot because I remember when it worked perfectly with the correct boot card. That was almost two years ago, before putting the cam in the drawer, but still...

  6. Piotr Deszkiewicz reporter

    Guys, you are geniuses. I did everything as you suggested and now it looks like the cam just needed to think it through. Many thanks!

  7. Piotr Deszkiewicz reporter

    I backed up all the files (including your diagnostic autoexec.bin file) and replaced autoexec with the "basic" one from EOScard. The camera now works perfectly with this particular boot card! Can you please tell me now how to restore the cam to factory settings (without ML)? It won't boot on any other card (just tried), only on this one that we prepared together a short while ago.

  8. Walter Schulz

    I strongly recommend not to touch (=installing/uninstalling) anything right now. Let a1ex jump in. He knows how to tame such beasts not working with standard cards anymore.

  9. Piotr Deszkiewicz reporter

    Ultimately it started to work with ML boot card and blank ones (normal mode), so maybe I'll just leave it be... That's some moody camera for sure! Thanks again guys, you saved the day.

  10. Log in to comment