Q scale Recording problem 550D

Issue #323 invalid
Crile created an issue

Hi all,

For the last couple of days I'm using ML now and I'm trying to figure out how to get Qscale to work.

I'm using my 550D I updated it to canon's 1.0.9 firmware. I'm using two different SD cards,

1 - 16GB Sandisk Extreme SD HC Class 10 30MB/s

2 - 16GB Sandisk Extreme Pro SD HC I Class U1 45MB/s

I Formatted both cards in camera

I used EOScard 1.0b2 as instructed, I checked FAT32, EOS_DEVELOP and BOOTDISK and saved. It said: "Write succesful"

I used ML:

magiclantern-0.2.0.rc1.550d.fw109

I followed all the instructions and everything seems to work just fine, all ML functions are accesible and without changing any setting I can shoot as expected.

I also used:

magiclantern-2011Jan28.550d.fw109.AudioMon.expo-settings.alex

magiclantern-2011Jan30.550d.fw109.AudioMon.misc-tweaks.alex

All version, even after re-format en re-install are having the same problem.

FOR THOSE OF YOU WHO WANT TO SKIP TO THE PROBLEM

PROBLEM:

From Qscale -10 to -16 it just doesn't work. After about 2 seconds recording stops automaticly, sometimes even without the buffer showing, other times the buffer is showing but just shows 1 blok, the bottom one.

On Qscale -10 tot -12 I have been able to shoot some clips, but only underexposed shots. As soon as everything is correctly or slightly overexposed it shuts down immediately.

The highest bitrate I got on one of this shots which stopped after 2 seconds is 74,98 mbit/s

So the question, what is going wrong, or what am I doing wrong.

Any help is a appreciated.

Comments (11)

  1. Crile reporter

    The cards cant be too slow, the 16GB Sandisk Extreme Pro SD HC I Class U1 45MB/s is the fastest SD card currently for sale in the Netherlands. And Sandisk is an A-class brand, so it seems to me that its not likely that I've got two bad copies. Please correct me if i'm wrong.

  2. Alex

    Also try disabling zebra and focus peaking (turn them all off with global draw). But since you said it failed with 0.2.0, too, I doubt these have any significant effect (movie recording uses very little ARM processing power after my observations; it takes place in DIGIC).

    All electronic parts (including those from top manufacturers) can fail or can work outside specified parameters. I've returned myself a 15MB/s Sandisk card because movie recording stopped after 20 or 30 seconds (with my 550D, without ML).

  3. Former user Account Deleted

    First of all thank you for you're quick responses.

    I turn'd of global draw and at first with an underexposed image it seemed to work up to Qscale -16, but when I evaluated that footage with Quicktime it had bitrates of just 40 to 42 mbit/s. I then changed my iso from 100 to 400, which overexposed the shot and tried again. This time, again, it immediately stopped recording. I tried this twice.

    first time: it stopped after 1.76 seconds with a file size of 20.23 MB and a bitrate of 96.44 mbit/s second time: it stopped after 1.68 seconds, filesize 20,42 MB and a bitrate of 101.93mbit/s

    My cards are 30MB/s (240Mbit/s) and 45MB/s (360Mbit/s) so both cards should handle this kind of bitrates easely.

    Is there a good way to test the actual speed of SD cards?

    Which brand and type of cards are used by most 550D/ML enthousiasts?

  4. Former user Account Deleted

    Some cards are fast in burst mode, but slow when seeking (i.e. slow when writing lots of small files). Movie logging may cause this, so try disabling it, too.

    For speed test, you may try HDTune (I believe it works for cards, too, not only for HDDs).

  5. Crile reporter
    • changed status to open

    I disabled movie logging, but it did not change the behavior of the camera. I think i will just give up and keep Qscale of. Thank you for trying to help me.

  6. Former user Account Deleted

    This is the only topic I found that talks about the 550D and the Sandisk 16GB Extreme Pro , so Im going to ask for help. Im using the same 16GB sdhc card on my canon 550D too. When I put the rec video mode in 1080p it says that I only have 29min of available time (when the card empty of course) Is this normal? Souldnt the camera recognize about 45min of rec time? My 8GB extreme pro capacity is 23min in Full Hd. Should the 16GB be twice that much? Is there sth wrong with the camera or is it the card (format etc...) Any help would be most welcome.

  7. Log in to comment