Picture Styles not working

Issue #396 resolved
waltoncr created an issue

Hey Folks,

I just installed 13MAR11 build in my T2i. This is the first build installed on this camera. Everything seems to work very well except for Picture Styles. I have tried to load them with the ML firmware running and without. They seem to work normally until I switch the camera to video mode which causes the User Defined profiles to revert to Standard. I have found I can fiddle with these profiles in the camera menu and the changes do stick, but if I attempt to overwrite them using the EOS Utility they simply revert to the Standard profiles, as I had altered them in the camera. The really scary part is that this behavior is the same with or without ML running.

Any ideas?

Thanks,

Chris

Comments (9)

  1. Alex

    Try resetting camera settings (Canon menu).

    I'm able to use the Marvels Cine picture style (but it's displayed in ML as user defined 1).

  2. waltoncr reporter

    Tried that. No joy.

    I have been trying to use Marvels as well as a few others. The image on screen and resulting videos are definitely Standard profile.

  3. waltoncr reporter

    BTW, thanks very much for your suggestion. I appreciate the help. My camera does also so User Defined 1 on the left of the display but says Standard at the right.

    I have done a bit more fiddling and found that the custom profiles are available in still modes and indeed say Marvels... etc. However, if I switch to video mode or switch to live mode or even shoot a picture, the camera snaps back to Standard picture style so long as I am running ML. It not only looks like Standard, but if I press the Picture Style button in still mode it will now say S. If I open the still in the Canon software, the style is indeed Standard. Without the ML firmware running I can shoot stills with custom picture styles but not video. The camera really behaves as if there are two sets of custom styles loaded, some accessible by ML and video mode and some accessible by standard firmware in still mode.

  4. Alex

    If it says only S, that's a sign that ML code increased again too much and I have to trim it down. The new font will allow me to get rid of a large amount of bitmap data, which will help with stability.

    Did those settings work well in earlier builds of ML?

    Try a sligthly older build (maybe one with autoexec.bin as small as possible).

    I've just tested here, and changing picture style results in image changes visible in LiveView in both photo and video mode.

    It may be also a secondary effect of movie button remapping (try disabling it). I know that it doesn't remember kelvin setting when button remapping is on.

  5. waltoncr reporter

    Thanks again. Regarding your questions:

    Earlier builds: I have only just installed ML so 13Mar was the first build ever run on the camera. I did downgrade to the 19Dec build but no change.

    Size: The 13Mar build appears to be smaller than the 19Dec build. Any particular build you would recommend?

    Remapping: I didn't have it on.

    I wonder if the issue is with actual camera firmware installation. As I mentioned, the problem is still there in video mode if I insert an SD card that is not loaded with ML. I wonder if I removed the battery before the firmware had completely loaded. The light had stopped flashing for several seconds as per the instructions but the fact that this problem continues in some fashion without ML (I had been shooting with custom picture styles for months before hand) suggests the problem is deeper than the build.

  6. Alex

    Does it matter if you change picture style from Canon menu, or from ML menu?

    You can try the Mar3, or Feb23 builds for example (those worked well for many users).

    If you clear the custom picture styles, and just customize their settings from Canon menu (without uploading them from EOS utility), are they applied correctly?

  7. waltoncr reporter

    Canon menu and the ML menu give the same results. I have cleared the styles and adjusted the settings from the Canon menu. These changes do stick and the altered picture style becomes what I would call the second set of picture styles in the camera, the first set being the ones uploaded by EOS Utility which are only accessible when shooting stills without ML.

    I will give the other two builds a try shortly. Thanks again for the very prompt response.

  8. waltoncr reporter

    Once I loaded the 03Mar build, stills began working again and I was able to adjust the video menu. I then reloaded the the 13Mar build and everything was fine. Very strange, but color me happy. Thanks again for all of your advice and hard work on the 550 version of ML.

  9. Former user Account Deleted

    I'm having the same problem with on my 60D, firmware 1.1.0, Aug 22 ML release. Any suggestions?

  10. Log in to comment