Display problem with 550d

Issue #421 resolved
Former user created an issue

Hi

I installed ML few days ago and it worked pretty well, but suddenly a problem appeared. After turning the camera on everything seems alright, but when ML loads the screen goes crazy. Menus and all the info in live view (but not the picture itself) are displayed in short periods reverted and then normal, and then reverted again and so. The zebras are flashing and I can't close the ML menu when I open it.

Comments (21)

  1. Former user Account Deleted

    When it started I had the magiclantern-2011Mar24.550d.fw109.tweaks.alex.zip but then I installed the newest one (magiclantern-2011Mar29.550d.fw109.topbar.alex.zip) because I thought it would help somehow. But it didn't.

  2. Alex

    Try deleting config file, or resetting camera settings.

    If it doesn't help, post a video which shows the problem.

  3. Former user Account Deleted

    I did that and now it seems to be a bit more stable but the screen still changes, however the ML menu is not reverted anymore. I noticed that it happens more often when I press buttons like menu or change settings with that small wheel. Also the camera took some pictures by itself with remote shoot options turned off.

  4. Former user Account Deleted

    Happens to me too :(

    Right after I installed Mar. 28 build, the OSD started to flip on.

    Only of Mar. 03 or older builds relieve this symptom :(

    HELP!!

  5. Former user Account Deleted

    I installed it and now everything works fine (zebras, focus peak, etc.), but now the image is reverted all the time ( only the menus, info and so, the live view view is normal and so are the images in play menu).

  6. kloned

    I have the same problem. In addition I want to mention that only native Canon's menu is flipped. ML drawings remains ok.

  7. Former user Account Deleted

    Tested again... It occurs on "magiclantern-2011Mar13.550d.fw109.AudioMon.zoom-overlay-x2.alex.zip" build or newer.

    Older builds worked fine.

    Hope this can help Alex.

  8. Former user Account Deleted

    same issue. I was on March 13 -- great, then March 22-- great, then March 29 -- magic zoom flashing, video mode hanging after almost every other time I press record, video record stopping 4 out of 20 times. Flipped menu screen when battery died. Then tried March 31 all the way back to March 13 in succession, every one of them has canon menu flipped screen. Magic zoom no longer shows up. (Magic lantern seems to start up immediately in video mode with the information at the bottom of the screen. Don't remember it starting up so fast) Didn't check other functions. I reformatted sd card, deleted magic.CFG. when I remove the sd card and turn on, camera runs fine.

    Mark

  9. Former user Account Deleted

    I am also experiencing this issue with mar13 build. Yesterday ML was working fine.

  10. Former user Account Deleted

    resolved? sorry but i just installed the 31 Mar build, and it still happens. the text is mirror-flipped (left-right). it sometimes happens immediately when the ML loads, and sometimes it takes a couple of shots or views of taken shots. i tested that 31 mar version and every one before it until i found the one that works on my camera; it's march 11 that's the last safe one. i hope this is helpful. i'm willing to try stuff for you if you need more info. thanks!

  11. Former user Account Deleted

    at this point i don't know if it's an april fool's joke that has outlasted its welcome, having been going for three weeks, or... if it's an actual bug. but i was too quick to say 'um, scratch that' last night. the 11 mar version is the last happy update on my t2i. and i definitely appreciate the -10EV FEL that occurred just before then, so thanks ;-) but... it's bizarre that not everyone is having this issue. it doesn't seem to care which lens i have on, and someone else suggested changing the date, which i did, but to no avail (both changing to 3 apr 2011 and also changing to 3 apr 2012). if i'm providing entertainment for someone, cool! but i would like to know what's going on. thanks

  12. Former user Account Deleted

    tried mark's approach above and that worked. thanks mark! reformat, re-cfg and we're back in business with the latest.

  13. Former user Account Deleted

    not sure if mine was the same problem as everyone here but my screen was displaying the wrong info bar at the bottom of the lcd, the stock canon instead of the ml info. after much experimentation, resetting, reinstalling etc I realized that pressing the info button while in liveview mode would cycle through 3 versions of the display, 2 canon stock, & one ML. Solved my issue so though i'd share.

  14. Log in to comment