550d not reqognizing sd cards, black screen.

Issue #509 resolved
Former user created an issue

Installed ML and it worked fine, I used my mobile memory card, because my 16gb "silicon power" didn't work. I thought if I put this "autoexec.bin" file to my 16gb, it would work, but it doesn't. It works fine with mobile 1GB card, ML works, but if i switch to 16GB card, nothing happens, only numbers in viefinder are visible, autofocus works, even flash pops up, but nothing else. I tried to format cards and camera, still nothing. I made 16gb card bootable, nothing. Only the smaller card works.

I'm using magiclantern-0.2.0.rc1.550d.fw109

So, how can I format everything and go back to my 16gb card ?

Comments (5)

  1. Former user Account Deleted

    I meant that i reuploaded the 1.0.9 firmware.

    I got it back to work now. I had to put the older ML (0.1.9) i guess, and then added the line to cfg file, it didn't work with the latest release...

    What do you think, what caused this when I upgraded my camera from 1.0.6 to 1.0.9, as ML needs, i couldnt use my 16gb memory card? It just didnt load that fir file. After that, if I used my other card, i got it perfectly done. I don't know, ML seems so good for me and I'd like to try it out, but I still need my 16gb card... Could it be something because it's SDHC or class 10 ?

  2. Alex

    I'm not sure you have followed the install procedure properly.

    The FIR file needs to be run only once to set the bootflag. After this, delete it. You don't have to run it again (unless you disable the bootflag).

    Then, you need to format the card, make it bootable and copy autoexec.bin and related files.

    I'm using a 16GB class 10. You may try with another card reader or another computer or operating system.

    Also try with a more recent build (May 17 for example).

  3. Former user Account Deleted

    My card does not work, why?? If I put .fir file on that, and navigate in camera to "update firmware" then it stucks at "Loading" screen. I just bought the card and it's definitely not the cheapest.

  4. Log in to comment