AJ 5.0 Bricked my Camera

Issue #519 on hold
Former user created an issue

5d mark II froze while taking a still photo running AJ 5.0. Turned it off - will not turn on again. Tried removing battery, different batteries, other CF card, no card, leaving Camera long time without battery - cam is completely dead. No LED light, display, viewfinder, anything.

Comments (6)

  1. Former user Account Deleted

    Anonymous,

    Q1) Was your 5D2 on 2.0.4 when you downloaded the firmware?

    Q2) When you had a problem -> did you take the battery out immediately? (which is the only way of stopping the software from possibly running in a tight loop).

    Q3) Was the configured the camera to 'Autoboot'?

    If yes -> Long shot i) Format your CF on a PC / Mac ii) Make it bootable iii) Download AJ 5.7 onto card (ie all 4 files) -> put in 5D iv) try switching your camera on now.

    Q4) What was the camera doing immediately doing before taking a picture?

    Q5) How long had you used AJ 5.0?

    AJ

  2. Former user Account Deleted

    Hi AJ,

    1) Yes, I first downgraded to the 2.0.4 Firmware I found here: http://www.moiraobrien.com/magiclantern/ 2) Yes, I took out the batteries (Battery Grip) immediately 3) Yes 4) I had just turned it on an made one still picture (I wasn't in live view mode). The camera froze while taking a second still picture (mirror stayed up, mechanical anti-shake whirring, no button responsive. When I turned it off the mirror came down. Since then - no reaction whatsoever) 5) For maybe 10 hours total. I had several freeze-ups which always could be remedied by taking out the battery and restarting.

    I brought the camera to a Canon service place so I currently don't have access to it. I will advise as soon as I hear from the repair people.

    Regards

    Jan

  3. Former user Account Deleted

    Jan,

    Thanks for the response to (3).

    Here is what I think happened:

    1) Your camera was set to auto-boot. This setting is actually stored in the 5D camera.

    2) AJ 5.x is geared towards taking Movies and not Pictures (ie I've done little test of exiting LiveView and taking pictures).

    3) When you took a picture, the DryOs (canon firmware) was unhappy when it wrote to the Compact Flash card. This changed something on the card that effected the Autoboot sector on the card / and or ML startup.

    4) To solve this, you need another CF card with ML on it, and the 'Autoboot sector' written to the card.

    5) When you startup the 5D, you camera would attempt to autoboot, find the sector, and work again. Without the bootsector + ML -> your camera will not startup

    AJ

  4. Former user Account Deleted

    Service Center says: Mainboard is fried and has to be replaced. Costs about $570.

  5. Former user Account Deleted

    Hello AJ,

    your description makes sense - but I tried just that (autobooting from a different CF card with ML on it) before I took the camera to the repair shop.

    Regards

    Jan

  6. Log in to comment