Bricked T2i after a white screen on boot

Issue #536 on hold
created an issue

Hi, I think I bricked a 3 weeks t2i, I'm kind of desperate. I've been using ML for 2 weeks or so, as sign of malfunction I just had an err80 that forced me to take batery out everytime I pushed trhee or more times the menu btn and some redrawn isues that dissapeared after i passed the finger over the lcd face detector. Apart from that everything worked perfect and made some great thinks with ML. I can't imagine using T2i without it.

Yesterday after shooting with intervalometer i took some more pics and shutted it off. Later I picked it up again and when I turned it on a white screen flashed on the lcd and nothing else happened, no leds, no focus, no err msgs, no matter what i did it's just dead.

I charged battery, left it 12 hours without it, tried to boot with other card or without any. All with the same result: nothing, like if it had no battery at all.

Is there any hard reset I can try without avoiding warranty?

I'm about to take it to the seller and see if he changes it, but I have to mail it and will take a couple of weeks minimun.

Cheers, Theremar

Comments (4)

  1. Alex

    What version were you using?

    Usually when the camera doesn't start, you can still see some info in the viewfinder.

    There is a debugging console in the camera (FROMUTILITY), but we don't know how to access it yet, sorry.

  2. theremar reporter

    Hi a1ex, thanks for answer fast. version was magiclantern-0.2.0.rc1.550d.fw109 over upgraded canon firmware 1.0.9. No signs of life in the viewfider neither, I'll do some research on the debugging console you mention, but I'll sure send it to warranty service, maybe it's a fault in which ML had nothing to do. I'll let you know any news.

    Don't be sorry, I knew the risks... theremar.

  3. Log in to comment