T2i/550d bricked?

Issue #586 invalid
Former user created an issue

So, I've had my T2i for about 6 months. I ran it with the latest canon firmware for 2 months, and then tried out ML. I went on a rap video shoot and it started acting wonky (menus not responding). I didn't have access to the internet at the time, so I asked a friend whom told me to just "delete ML from the card" yeah... wrong.

The camera would not power on after that. I took out the battery and card, and tried formatting it in my zoom h4n, which actually worked.. the camer booted back up and we finished the shoot.

I didn't use it for a month or so, other than to take a few photos and do some home videoes, and then i used it again for a vacation.. all was well. Then i didn't use it again for a few weeks, the next time i tried to use it. It once again wouldn't power on. i took the card and battery out.. left them out overnight.. still no go.

I put the card in my card reader and noticed there was some H4N files still on it, so I formatted it in the pc.. put it back in the camera, and it powered on.. everything was fine..

A week passes, and I use it to shoot some test footage.. everything is fine. I took it out for another shoot a few weeks ago, and again.. no power. So, I go home and try to attach it to the pc wth usb cable.. powered right up.. so at that point I reinstalled the 1,0.9 firmware and all was good.. until the next time i tried to shoot with it..

It was on for about 3 minutes, and the screen flickered and the power went off.. and it has been dead since.

I've been perusing forums and trying everything I can think of, and nothing has worked permanently.. different batteries, different cards, checked all doors, etc.

I've got the warranty return info ready, but I fear ML will still have a trace left on the camera which will mess up me getting anything done without a high price tag.. I was hoping I could figure out whats wrong with it so I didn't have to go that route. My camera worked flawlessly up until I installed ML.. I'm not blaming ML its just the only that I know of thats changed between the time it was working and now.

Comments (7)

  1. Former user Account Deleted

    Hi! I'm sorry for what happened. I can't help you, since I'm no expert of ML.. we should await a response from Alex. Were you running the latest ML unified version? When it turned on for 3 mins had you the Canon 1.0.9 firmware installed? If yes I think the boot flag changed by ML to the camera firmware has been restore to its original value, so your warranty should be safe.

    Well, since there's no much word about the behaviour of Canon in case like these, can you please tell us how it ends up with your camera? I mean, if they will charge you a price or something.

  2. Alex

    The first "mistake" of deleting all ML files has nothing to do with this issue; I did this countless times. It will just freeze your camera until you take the battery out (but you will still see some info in the viewfinder).

    Right now, when you start the camera, is there anything displayed in the viewfinder? If yes, it's a bootflag problem (easy to fix).

    During those 3 minutes, what were you running, ML or Canon firmware? I don't know how exactly the flicker was, but it may be a hardware issue.

    If you say "nothing has worked permanently", does this mean the camera still boots, works for a while, and then it shuts down?

    Also, make sure your battery is charged; if you leave it in the camera after it freezes due to lack of autoexec.bin, the battery will be discharged quickly.

    I can compile a custom autoexec.bin which only blinks a LED. This will happen before trying to load Canon firmware, so if the hardware is alive, we may be able to reset the bootflag, or maybe even find out what's wrong (I'll try on my camera first).

  3. Alex

    Please tell me if this autoexec.bin blinks the card LED. You should only make a card bootable and copy it.

    If it does, the bootflag is still enabled and we can run code on the camera.

    If it doesn't, either it's a hardware failure (unrelated to ML), or the bootflag is no longer enabled (i.e. ML was fully uninstalled).

  4. Matt Banfield

    @a1ex Hey, Alex. I just happened across this forum while searching for a solution to my problem. I seem to be having the same problem addressed here, tried the autoexec.bin that you posted and it is blinking the card LED. What should be my next step?

    Thank you for any help, and if this isn't the correct place for this question, I apologize.

  5. Matt Banfield

    @a1ex I appreciate your response, but I think I fixed it.

    I wasn't seeing the "modules" menu on my camera running Magic Lantern. I was attempting to uninstall/reinstall ML on my t2i by deleting all of the ML files from my card. After deleting the files, my camera wouldn't come on at all.

    Eventually, I pulled the card and battery. I formatted the card on my computer and put a new battery in the camera. Before reinserting the card I tried once more to turn it on. It came right on as normal, so I turned it off, put the card back in, and powered it back up.

    Everything seemed to be working fine, so I reinstalled ML on the SD card, upgraded the firmware on the camera, and it appears that everything is back to normal.

  6. Log in to comment