Cant Uninstall ML from Camera

Issue #625 duplicate
Former user created an issue

Tried to firmware update from Inside ML. Get green status screen for one second then it disappears. I have tried moving the wheel as it says but bootflag remains and I can not go back

Comments (16)

  1. Former user Account Deleted

    I do not see that.

    What do I need to change.

    I have seen the screen that says ML is not installed, but as soon as I eject the card or battery it starts searching for firmware.

  2. Former user Account Deleted

    Even when I boot with half shutter press into Canon FW. As soon as I eject the card and put it another one it says the updater file is missing. It only wants cards with ML even when booted into canon Firmware????

  3. Alex

    How did you do to get the camera ask for updater? Did you try to press any buttons while the screen was off?

    I've had the same problem on my camera (tried to enable bootflag in movie mode), and I've solved it by reinstalling Canon firmware.

    To get that screen from my link, you had to press INFO a few times.

  4. dreamoncreative

    Saga continues.

    I reformated the card in camera per unsinstall instructions. Rebooted camera and get an error message.

    "Update File cannot be found check the memory card and reload it.

    This is frustrating

  5. Alex

    The problem was at the install stage (it has also set the Firmware flag, not only the Bootdisk flag).

    A few questions:

    • When you installed ML, how was the install process?
    • Did you get the green confirmation screen?
    • Did you get ERR80 or other error?
    • In which mode were you when you installed ML?
    • Were you in LiveView?
    • Did you have to remove the battery, or did the camera turn off properly?

    Now, you can fix this by installing Canon firmware (just place their FIR on the card). I did this around 5 times on my camera (I was getting the same message, "Update File cannot be found"). I've caused this by trying to set the bootflag in movie mode (as a stress test); this resulted in image freezing, camera crashing, and camera asking for firmware update.

  6. Alex

    Found the bug. When display is set to off, sensor cleaning message will appear full-screen. In this case, it's not safe to set the bootflag (it will freeze and it will also set the Firmware flag).

    Will be fixed asap.

  7. Former user Account Deleted

    Hi a1ex,

    I'm also suffering a similar problem whilst trying to uninstall ML. I have booted up with my ML card on my 60D (fw 1.1.0), gone to the firmware update and have followed the screen where it prompts to turn the mode dial to disable boot flag (which I have done), after this, it takes me to the next screen saying "BOOTDISK flag is DISABLED, ML is NOT installed, you may restart your camera, after reboot, clear all the settings and custom functions to complete the uninstallation".

    So after that I turn my camera off (also tried removing battery), but when I turn it back on, it boots into the firmware update mode, back to the screen asking if I want to disable the bootflag.

    What is the best way to resolve this? Should I format the card, and put the canon stock 1.1.0 firmware on, and try and boot off that? Also what is the FIR you have mentioned? (I have "ml-60d-110.fir" on my SD Card).

    Thanks in advance. James

  8. James Pittendreigh

    Sorry, just bumping this now I have a bitbucket account so I am notified of responses. Thanks.

  9. Alex

    Either use the Aug28 FIR to fix this, or reinstall Canon firmware (just like you said). Just copy the files on the card (the camera will run either the FIR or the autoexec, depending on bootflag setting)

    All older installers are buggy on 60D if they are started with display off.

  10. James Pittendreigh

    Thanks a1ex, that has worked (I used canon firmware as I had that handy). I was worried for a second that I was stuck in a failure loop. I actually just did it to see how easy it was to revert back to stock, should I need to. Very impressed with the focus peaking though, so I will be re-installing later.

    Incidentally, I have struggled to find information in the ML manuals/install docs about how to update the canon firmware, so that you can then update the version of Magic Lantern. Would you have to un-install ML on the camera body, upgrade to the new Canon firmware and then add the updated version of ML to the camera body (essentially as a fresh install) or is there a shortcut/easier way?

    Thanks again, especially for your prompt reply! James

  11. Alex

    Exactly as you said. The easiest way is to format the card, then update Canon firmware (just as they say on their website), and then install ML again. With the latest FIR is really easy to install (just copy the files and run FW upgrade).

    The shortcut is skipping the format step; it may work, but some cleanup is good, so it's not recommended.

  12. Former user Account Deleted

    i don't think this was fixed in the aug unified release. i tried installing ML on a 60D by following the steps in the wiki exactly. when i set the camera to update to ML firmware, a partial sensor cleaning message (no green msg) came up and the camera seemed to hang. i re-inserted the battery and to my surprise ML was working. but now if i don't insert a ML card the camera gives me the updater missing message and hangs. even if the camera is turned off and i re-insert the battery with no card or no ML card the camera gives the error message.

    i've fixed the problem by going back to canon firmware. but the install page on the wiki needs to be updated.

  13. Former user Account Deleted

    I am unable to re-install the canon firmware, even though i put it on the card, the only option is to update the magic lantern firmware. Help!

  14. Log in to comment