500D FW 1.1.0

Issue #629 resolved
Former user created an issue

Hi

Im new to this but i have firmware 1.0.9 on my 500D and i can only find firmware 1.1.1. Do i have to have firmware 1.1.0 to install Magic Lantern?? If so where can i download it, can't find it anywere?!?

Comments (3)

  1. Former user Account Deleted

    Hi

    Same situation here. It seems Canon has removed the 1.1.0 firmware from their website as it is now outdated and replaced by the 1.1.1 version. Unfortunately all references to 1.1.0 I found on Google lead back to the Canon website and end up as a dead link. Will ML be updated to work with 1.1.1 on the 500D?

    Thanks

  2. Log in to comment