1. Trammell Hudson
  2. Magic Lantern
Issue #747 invalid

60D Firmware update does not complete

Anonymous created an issue

With my SD card low level formated in the 60D camera, camera settings cleared, October 14 ML files copied to the card, camera in Manual, when I select Update Firmware Ver. 1.1.0, the screen displays "Firmware Update Program Loading..." then the screen goes blank and the red LED on the back right of the camera flashes but nothing else happens. I have to pull the battery to get the camera to respond again. I've tried the October 14th and October 19th and August 22nd versions with the same result. I low level format between different version attempts. I've tried two SanDisk Extreme 32GB cards and one SanDisk Extreme 16GB card.

Comments (7)

  1. Anonymous

    me too... have tried it a couple of times... twice with a 16gb SDHC C10 card, didn't work. And then I tried it on an old 8gb C4 card. Both times, same thing, said it was loading and then screen went to black and the RED light just blinks.

  2. Anonymous

    I have the same problem too... correct firmware, tried with SDHC card and SD card, made card bootable using EOScard.exe.. nothing.. i still get the black screen after flashing

  3. Anonymous

    I've no idea why the card class/type/capacity would have anything to do with it. As for the "correct firmware," did you reload the firmware from the install page link as directed (it really is a necessary step for some, myself included). If you've done so, be sure to state it explicitly (if you expect a chance at an unpaid support response).

  4. Anonymous

    I've exactly the same problem with a 60D, I tried with lexar SDHC 16GB and sandisk extreme 16 GB cards. The firmware version is also 1.1.0. and I by the camera the 15 january 2012. helps...

  5. Log in to comment