550d not responding

Issue #752 on hold
Josh_carver created an issue

Hi, could use some help as my 550d has stopped responding. I was using sep22nd build, but the live view in the camera kept going off. It would take pictures but would not sustain live view or movie mode.

I tried a lot of things- different batteries, cards, removed magic lantern from one of the cards. Nothing has fixed it and now it is even worse. The camera will turn on but usually just says BUSY. If I can get into menus then it tends to just freeze and not respond very quickly.

The only advice I've been given ( by the camera shop) is to leave it without battery for a while, and maybe change the internal battery (though I doubt this will make much difference, and don't know where it is anyway)

I'm not certain this issue is to do with ML, I have no idea what's wrong with it and appreciate any help anyone can give!

Josh

Comments (84)

  1. Josh_carver reporter

    Thanks, I have just cleared settings but it makes no difference. Curiously, the camera seems to run fine with no card in the slot, but as soon as I put the (formatted with ML removed) SD card in and start it up, it just says BUSY and freezes.

    Do I just put the autoexec file on the card and start up the camera with it?

  2. Josh_carver reporter

    I put in on the card, but it still just says busy and won't do anything. (though viewfinder sensor to turn the lcd off when covered still works)

    Does fomating the card in the camera make it non-bootable again? I could put it through macboot again.

  3. Alex

    What version is displayed in Canon menu?

    That autoexec does nothing except for saving a file (see the card LED). It won't show anything on the screen.

  4. Alex

    If you can't run autoexec.bin, run "firmware upgrade" with august22 version. Disable bootflag in the camera, then restart the camera and run "firmware upgrade" again. At this point, it will save the log file.

  5. Josh_carver reporter

    It hasn't saved anything on the card (that I can find anyway)

    I managed to get into the menu long enough to disable bootdisk. Restarted and it just says BUSY and freezes again, with both cards. (one has aug 22nd on, the other has nothing on.

    Can't find a log file...

    Still seems to work okay when there is no card in the slot.

  6. Josh_carver reporter

    It won't let me do anything at all with a card in, without a card I can access the menus just fine but obviously can't do the firmware upgrade like that. Not sure what to try now.

  7. Josh_carver reporter

    Am using 2 cards, both Transcend 16gb class 10, have been using both for a good while now.

  8. Josh_carver reporter

    It says BUSY on the LCD- at the top in photo modes, at the bottom in video. if I half press the shutter than in also says buSY in the Viewfinder in photo modes.

  9. Josh_carver reporter

    Also, I can't change between modes when it says busy, the dial doesn't do anything. But it'll start off in the mode that the dial is set on when it's turned on

  10. Josh_carver reporter

    Okay, interesting... I tried connecting it to the computer without card, EOS utility came up, and I could take pictures saved to the computer, see live view, everything. Tried, with the card in expecting it not to work but it did, could record video onto the card (via the record button on camera) and play back, take photos, access menus, everything. When I tried again disconected from the computer, it gave a BUSY, which then went away and I could use the functions, but it didn't last long and locked up again when i went to video mode. Tried the same thing with taking photos and it wokred at first, but soon froze up with BUSY.

    Now, just plugged it into the computer again, but this time not going to remote shooting, or touching anything on the computer (the eos utility thing pops up on it's own), I can use the camera completely, with the card in. can record movies and everything, no issues, and the only difference is the usb is plugged into the computer! It's good to know the camera itself is working but i don't understand this at all!

    But, seeing as I can now access menus whilst plugged in, should I do the firmware update to install boot-flag again?

  11. Josh_carver reporter

    Just thought I should mention- this may be completely coincidental- but i haven't had this problem before today, and it started happening very soon after using an external mic plugged in and on the hotshoe, which i have never done before. Just wondering if maybe there is a bug that caused a weird error because of the mic being used? Though, taking it off made no difference so I doubt it. I have actually noticed the camera getting the busy sign a lot with bursts (in raw) lately and being sluggish with this, but seeing as I don't used bursts very much I wasn't sure if this was normal or not.

  12. Josh_carver reporter

    I re-enabled diskboot but found no Log. So I used that autoexec file you gave me and this time it did save a log on the card, here it is.

    Hope it can shed some light...

    Thanks

  13. Alex

    Great. The log seems to be taken in LiveView, can you create one in regular photo mode?

    Busy messages in burst mode are normal (the buffer fills up).

    At this point I can't tell what it is, but being able to run code and save logs is a very good sign.

  14. Josh_carver reporter

    For this new log the camera was in av mode. Turned the camera on, the screen was blank, just god the red led for a little while, which then went off.

    I tried it again (LOG 2) pressing some buttons this time, putting it in photo mode, video mode, taking some photos and bursts. everything seems to work except that the liveview/record button is doing nothing. (though, the liveview does come up in video mode.)

    Tried it again with aug22nd back on the card and the liveview button now works and I can record. No problems noticed but i did only try it for a couple of minutes. This is all without being plugged in to the computer or anything else, so a good sign! Although, the usb was still plugged into the camera, but the other end wasn't plugged in- i did take this out on the last test to see if it made a difference and it doesn't.

  15. Josh_carver reporter

    No, it's not working properly. Obviously better than it was before as it was yesterday because it wouldn't do a thing, but just tested it taking photos in live view and once again the live view eventually closed and BUSY came up. Made another log after this (the camera wasn't responding after turning it on to make the log, just stuck in video mode)

    I've no idea what to try now, though I'll do some more tests with the usb plugged in

  16. Josh_carver reporter

    Since getting the BUSY freeze again it has rapidly become worse and is pretty much back to how it was yesterday. But again, no issues whatsoever with no card in the slot, or with the usb plugged into my mac. (is there any bus power going on between the computer/camera? Why should the usb make a difference?)

  17. Alex

    EOS utility alters the busy flags, so it seems it can be used as an workaround.

    This autoexec clears the busy flag every second, it might help. I'll prepare another one soon.

    Since the camera stopped responding after writing the log, there may be some problems with the card slot (poor contact?)

    I also have a card slot issue with my 550D (from too many inserts/removals of the card) and I need to insert a piece of thick paper for the card to work (to push it on the contacts).

  18. Josh_carver reporter

    Thanks alex, that does seem to stop it from freezing up completely but the original problem still remains unfortunately.

    In testing, I was able to take a lot of photos in live view, with screen going back to photo/mirror going down only once or twice. I recorded a lot of video, and let it run until it began a new clip. 8 seconds into the new clip, suddenly the shutter goes up and it becomes very temperamental again. it also does this in play mode sometimes- you hear the mirror go and the screen reverts to the standard photo mode screen. (possibly gets worse as it heats up?)

    Do you think there may be a physical problem with the card slot then? I tried using the thick paper but it made no difference.

    Or could it be some sort of power issue? Perhaps it it shutting off liveview because it's not delivering the power to run it properly?

    I very much appreciate all the help and will be donating!

  19. Josh_carver reporter

    (always have planned to donate once I get a regular income, but think i will be doing this much sooner now)

  20. Josh_carver reporter

    Been testing some more with the usb- as always absolutely no problems when plugged into my mac. So maybe whatever the canon software is doing, it's solving the problem. However, I also tried quitting the canon software and continuing to use the camera whilst plugged in, but with the canon utility closed. Again, this all works fine, except that after taking photos (which then pop up on screen for a few seconds), the live view doesn't return, and nor does the mirror drop, this has to be done by pressing the liveveiw button- once for the mirror (to be able to see through the viewfinder) and again to get the liveveiw backup. Video mode doesn't do this though and works fine. This behavior is unique to the usb being in but not the software (it was the same when i plugged it in once yesterday but canon utility froze, and didn't pop up)

    Am I right in concluding that if it's working fine whilst plugged in, it can't be a physical problem? unless there is something that is not working within the camera but that the computer can provide independently? Also, seeing as it works fine with no card in as well, then the problem must be something to do with that? To clarify, when using with usb I am not doing anything with the canon software at all, i simply plug the camera in and use it as normal. What can the mac and/or software be bypassing? Still a bit baffled, but perhaps you'll be able to isolate something from my descriptions.

  21. Former user Account Deleted

    Hello,

    I was reading this as I have become interested in Canon EOS cameras and the Magic Lantern software, neither of which I own. I am no expert, but it does sound like it could be a power/battery issue and that maybe the camera is being supplied the correct voltage when connected to the computers USB but lacking enough voltage to work correctly when using only the camera battery(s).

    Hope you solve your problem soon.

    regards, Simon

  22. Josh_carver reporter

    Thanks for your thoughts Simon, can you confirm that the computer can indeed supply power to the camera via usb, or is it just a hunch? If so then it does seem likely, though i'm not sure why not having a card in the camera solves this. I'm wondering if, if it's not fixable, getting a battery-grip might be a workaround...

    One thing that the guy in the camera store suggested was changing the internal battery (the time/date one/backup one) though he didn't know where it was located. However, it seems unlikely to me that this would be the problem, because if it was surely my time/date and settings would be screwed too, which they're not.

  23. Josh_carver reporter

    By the way, I have three batteries (one official canon, and two non-brand ones that have worked just as well) so I doubt the batteries themselves are the problem.

  24. Alex

    You can't change the internal battery from 550d afaik (and I doubt this is the problem).

    I believe Canon software also does a similar workaround as my autoexec. Not sure yet what's going on.

    What's your shutter count? Might be related (but in this case you should get ERR20). Mine sometimes does weird sounds in play mode or in menu mode (like it's losing control somehow). My shutter count is around 120.000 now.

    Can you boot the attached autoexec in M mode? Don't try to go to LiveView. Wait for 1 minute or so, and it should save a log file (look at the LED). Hopefully this one will be no longer trimmed. You can try to run it a few times; if you get busy status with some tries, and you don't get it with others, write down which is which.

    The autoexec does not start ML tasks (it only rewrites version string in Canon menu and saves the log).

    The problem might also be solved if you reinstall Canon firmware, but it could also do worse. I would only try it as a last resort, because it could write corrupt data into ROM.

    Side note: we are in different time zones, so we may not sync very well in replies.

  25. Former user Account Deleted

    Josh, with further reading it seems that the PC USB doesn't supply any power to the camera.

    Simon

  26. Josh_carver reporter

    Here are 3 logs- first time i started it in Av because i forgot it should be in manual, second time it was in manual. I received no BUSY flags, not even to start up (which was happening yesterday with your autoexec, before clearing). I expect this is just because it has been left overnight, because this seemed to help yesterday as well, but it soon started going wrong again. I then did a third, to try liveview but can't actually access liveviwe with this new autoexec. I can get into video mode and see the live screen but the liveview button doesn't work to start recording. That's the only problem so far today (but i expect it'll start acting up again soon.) Now testing on yesterday's autoexec, had a brief 'BUSY' already. Shutter count is 26351. it says 12148 pics + 14203 LV. though one of the last things i did before this was a rather intensive wedding that probably added 3000 to the shutter count, it was about 9000 before. when i took it to the camera shop the guy said he couldn't see anything wrong physically, he didn't think it was the shutter.

  27. Alex

    Shutter count is not a problem. Logs show the entire startup sequence, but there's no sign of malfunction (as far as I can tell).

    I had a somewhat similar startup problem (err70 at every startup, even without ML, no menus could be accessed). It was after trying to reproduce an err70 crash in movie mode (and after 100 tries or so, the error stuck there). I was able to get a startup log and found there the reason (picture quality setting had some incorrect value).

    Do you remember what you did before starting to have this problem?

    I'm confident we can fix the problem, but give me a few days to investigate this a bit more.

  28. Josh_carver reporter

    I'm not surprised the logs show no errors, i didn't get any errors whilst booting the autoexec for the log. I can keep trying though to see if i can get an error with that on the card, but it seemed to be working except the liveview button not doing anything (is this intentional?)

    before it started going wrong, I plugged an external microphone in, it has it's own batteries though. But seeing as I have never done this before (it's not my mic) I wondered if this could have messed something up. We did a test with the sound and played it back on the mac, but it was just hissing. Realised i had forget to turn the mic switch on. We did it again with it on and it sounded fine. But when we came to start filming, it kept closing the shutter (you hear the click and the screen goes back to non-liveview). The wedding was the last major thing I have done with the camera before this (two weeks ago) and have been using an external flash, which I haven't used before. Don't see how this could cause a problem though. I'm using a Tamron VC 17-50, but when it started going wrong I also tried my manual lenses with adaptor but it made no difference. I haven't been getting any camera ERROR codes at all, the only one I have had recently was last night, it gave an error and said the pop-up flash couldn't be raised, but this was because the strap was caught over the top of the camera blocking it. I have been using the OCT 6 build of ML when it went wrong. This was the build that solved the problems I was getting with Error 70, that lots of people were getting.

    Can't think of much else. For stills I shoot RAW. I tend to use trap focus a lot, though i don't know if this was actually on when I started having the problem (i was in movie mode anyway) I do tend to use quite a lot of the global draw features on ML, and remap the movie button to A-DEP. I've been using Technicolor PP, though it's not on the camera right now because I cleared the settings. No external monitors or anything. I have had the camera almost a year and a half and it seems to be in good shape (one or two stuck pixels in photo modes)

  29. Alex

    Just got a similar symptom after running a stress test on 550D. Restarting the camera fixed it. Maybe it's related.

  30. Josh_carver reporter

    Well i have just been leaving it with the battery out for several days. Last time I tried, i didn't actually have any problems with the non-magic lantern card in. With the ML card, i do get a brief 'busy' at startup but seemed to be working after that. however, it has seemed like this before when I have left it overnight, and always started playing up again soon enough so I'm fully expecting that to happen again. Will have to test some more though.

  31. Former user Account Deleted

    Damn. Despite having no problems during testing this week, I was filming earlier (same short I was trying to film when it went wrong the first time) and though it worked fine for most of it, towards the end it started closing the mirror and shutting off live view on it's own again. This was only occasional to begin with but soon became pretty much constant. Changing cards/ batteries doesn't help for long. I was using the ML version with the busy flag fix that you made for me. Luckily I was able to get the last shot I needed by plugging the camera into my mac and shooting like that- as always it works perfectly when the usb is plugged in. Really don't have a clue what is wrong with it, or why is seemed to be working but has suddenly decided to mess up again!! Have you managed to come up with any ideas as to what the problem could be? It's driving me crazy...

  32. Alex

    With this autoexec, hit "Don't click me". It will create two log files with your settings: PROP.LOG and PROP-STR.log. When it's done, you will hear a beep.

    Before doing this, clear your settings, go to photo mode (P), and set "auto power off" to a few minutes (otherwise camera may stop in the middle of the process).

    I've removed the busy notification sequence from ML startup. Not sure if it's related or not, but now it's no longer needed.

  33. Josh_carver reporter

    Sorry, I have tried to do this but the 'Don't click me' option isn't there on this autoexec. Unless I'm being really stupid somehow. On the magic lantern menu most of the usual features aren't there, and there's no 'don't click me' to be seen...

  34. Josh_carver reporter

    That's not what I'm getting. I've attached a screenshot so you can see what I mean. I have one card with the older ML on (the version you made me the other week) and that has all the menus and there is a 'Don't Click Me' in the Debug menu. My other card has this new autoexec on, and as you can see there are only a few of the menu options appearing. There is a debug menu but no "don't click me " option- nor is that option any where else. Changing modes doesn't make a difference.

    In addition to that, I'm now getting busy lockups again on that card (it only just started happening again)- so don't know if i'll be able to access the menus with it now anyway. Though the older version with the cleared busy flags does stop it from freezing up still.

  35. Alex

    This autoexec will display the UI lock code on the screen. Tell me the code in normal (idle) state and when it gets busy.

    Then, when it shows BUSY, press SET to restore it (it should clear the busy flag). It will confirm with a beep, then will save a debug log.

    You can collect a few logs and attach them here. Hopefully one of them will contain some relevant info.

  36. Josh_carver reporter

    Idle code: 1579

    Then, it wasn't getting busy so I did a little movie recording (Code: 83000000). after a bit it closed the shutter and then i got BUSY. Code: 410005F

    However, pressing set didn't do anything and I was unable to clear it and no logs have been saved. I tried a few times and waited for a bit, but set isn't doing anything. None of the buttons respond when it gets busy (though curiously the veiwfinder trigger works and will turn the lcd off if I put my hand over it) so that may be why.

  37. Josh_carver reporter

    That one works at stopping the lock-ups, though again I'm still getting only a few ML options as per my previous screenshot. I put #26 back on there and that gives me the full ML options.

  38. Josh_carver reporter

    Any progress on finding out what those codes mean? I hate having my camera out of action!

  39. Alex

    Can you hit "don't click me" in http://bit.ly/ml-nov11 ? It will save two log files, PROP.LOG and PROP-STR.LOG, send them to me.

    Before doing this, reset your camera to defaults and then set auto power off time to a few minutes.

  40. Josh_carver reporter

    I can't do it with that autoexec- not at the moment anyway, it just freezes up with BUSY. But I can't find the Don't Click Me option anymore anyway, do you have to be in a certain mode? Used to just be there in the debug menu..

  41. Josh_carver reporter

    Oooh I see. Sorry, haven't been at home for a few days but just got back, and with the camera plugged in i've managed to have a proper play around and found the advanced settings (d'oh! not used to these new builds). Anyway, have done what you said and the logs are attached, though this was done whilst the camera was plugged in via usb, which I would imagine makes a difference. I will try to do it without but I'm afraid so far it just locks up. Would you be able to get me the same build but with the busy flags cleared again so that I can do it?

  42. Josh_carver reporter

    Now, this one might be of more use: what I did here was unplug the usb then immediately press don't click me. I got a BUSY freeze as expected, but the logs had already started so the logs were essentially taken during the freeze.

  43. Alex

    Interesting, there are quite a few interesting differences compared to my settings.

    I'd try to apply your settings to my camera to see if I can reproduce the issue. If yes, it's likely that the reverse will also work.

    Of course, first I'll try find out what each setting does.

    Just in case anyone wants to try: don't try this at home! Restoring the settings back may be tricky.

  44. Josh_carver reporter

    That would be great if you manage to do that.

    Any luck with it yet? I'm supposed to be filming on saturday but it looks like I'll have to borrow someone else's camera (with no magic lantern- this makes me sad!)

  45. Josh_carver reporter

    If you think it might work then it's it might be worth a shot yeah.

    Still trying to think what the software could be supplying/bypassing when it is plugged in, but haven't been able to find a thing relating to this or my problem in general via google.

    Once again i've left the battery out for a few days and it briefly works before starting to go wrong and eventually it'll start locking up completely. I find this quite odd- why would it do this?

    Don't know if i should contact canon but i don't know what they could do really. Probably just tell me to send it in, but it's out of warranty and I imported it from america anyway.

  46. Former user Account Deleted

    Hmm, I'm sure I posted on here earlier but it isn't showing up... anyway, I just asked how do I do that restore, another auto-exec? I'm willing to try if you think it has a chance of fixing the issues, and the risk isn't too high. As far as I understand it, the logs I gave you showed that there are some odd things going on in the settings, so resetting these may solve the problem?

  47. Alex

    Here it is (under "don't click me", it will call FA_SetDefaultSetting). What I know is that it's a Canon function intended for factory tests.

    After running it, restart the camera and you will find the menu in Japanese. Go to wrench 2 menu, third item, to set it back to English.

    I hope it helps, but you run it at your own risk. I've just tried this with the attached autoexec on my 550D right now, so it should be fine.

  48. Josh_carver reporter

    Okay, just done it. took a few times for it to work but the menus went to japanese eventually and i set it back to english. Magic lantern still works- should it? I would have thought the bootflag would be reset or something?

    Can't say if it has made a difference yet, will just have to test. Anything i should do now? Some more logs for you to see if anything has changed?

    Does this autoexec clear the busy flags? (i'm guessing not, but would be good to know)

    Thanks a lot, i have my fingers crossed for this one!

  49. Alex

    Yes, ML still works after this. I wonder why it didn't work from the first try.

    This autoexec does not clear the busy flag (it's the same as the nov22 version from the mailing list, but with this function at "don't click me").

  50. Josh_carver reporter

    Oh damn. I've been testing and testing and testing and it's been fine. But it's just started doing it again. I have no idea why... it's ben fine. Through several batteries (and worked fine even when battery was about to go) Recorded long stretches on video and maxed out the card and it was all fine. But it just started shutting off liveview again, happened once, then again immediately after.

    I have no idea why it would work fine then suddenly start doing this again for no reason. The only thing is that it started doing it after i enabled Movie Restart- but this is probably just a coincidence. I've turned that off and it's still doing it.

    Do you have any suggestions? I've no idea what to do about it now

    thanks

    Josh

  51. Josh_carver reporter

    By the way, I have tried doing the reset a couple more times but to no avail, it's still doing it. So maybe that didn't actually help in the first place, it was probably me leaving for a while that did it. Which I don't understand!

    Bearing in mind that it works fine: A- when plugged into usb B- without a card in it C- sometimes if I have left it for a while, but then will start up again with prolonged shooting (video)

    What could possibly be causing that?

  52. Former user Account Deleted

    Hey, I´m having simular problems with my 550d. I had ML 2011Oct27 on it and it was working perfect. But suddenly it just stayed black. I can´t boot my camera with any kind of sd Card, just stays black. I can start it without, can take pictures and go into live-mode. I can´t connect my camera to EOS Utility - it is saying camera not recognized (without sd card in) - with sd card in, its just doing nothing. But autofocus works with sd card in. Please help :) Thank you very much!

  53. Former user Account Deleted

    Is there a way to disable SD-Card Boot, without putting a SD Card into the camera? I just can´t boot my 550d with a sd-card inserted. Even a brand new one... screen just stays black - af works. Please help, don´t know what i can do. Thank you!

  54. Alex

    Autoboot can't be disabled without a card.

    Format a card, make it bootable with EOS utility and copy ML files. Does the LED blink when you start with it?

  55. Former user Account Deleted

    Thanks for your reply. I formated the card (Fat32) and made it bootable for ML with EOScard. Screen is just black and the LED is not blinking at all. AF works... so no change there. Tried 2 different cards and 2 different ML versions - nothing. Not even a short blink.

  56. Alex

    Could be a hardware issue with the card slot itself?

    When AF works, but display is still black, it's usually because the camera is looking for autoexec.bin, but can't find it. You may try the card in a second camera, to make sure it's OK.

  57. Former user Account Deleted

    Thanks again. The autoexec.bin does exist. Just double checked the card, on other Computer and other Camera - works perfectly fine. I can control the camera on the computer without a card in, can i get access to some log files of the camera? I still have warranty... so if I send the camera in now, could there be a problem? (might be little off-topic, sorry, i just don´t know what to do)

  58. Former user Account Deleted

    Hey, I found the error. It was a hardware issue with the SD - Card - Slot. One of the contacts just didn´t touch the SD-Cards.. for whatever reason it was a little bit bended. So easy to fix with a needle.

    Thank you very much!! Keep up the good work!

  59. Josh_carver reporter

    I wonder if my problem is similar (though your symptoms sound quite different so maybe not) How did you find out that this was the problem?

    A1lex- quick question, I contacted canon and they (eventually) replied and asked what cards i was using, saying that that cards above class 6 can cause problems inside the camera. I'm pretty skeptical about this as I can't verify this anywhere else and people i have spoken too say this is a bunch of BS. Do you know if it's true or not?

  60. Alex

    That's the first time I hear that class 10 cards cause problems...

    The other problem was completely different.

  61. Josh_carver reporter

    Yeah, I think they might be fobbing me off. And they asked for more details, which I gave, but they never replied to my reply. Brilliant customer support from canon...

    Yet again, camera seems fine right now but it'll eventually descend into madness again like it always does, I don't understand this pattern. Perhaps heat-related, but seems like too loose a connection as changing the battery doesn't make a difference and it usually needs to be left for several days to start working again. Unless it's triggered by something, but I don't think there is anything specific I have done every time to trigger it (though I think i have usually, if not always, been in movie mode when it has started). Maybe magic lantern is overworking it and once it reaches a certain point it triggers some sort of loop? I'm clutching at straws...

    Think it would help to disable to diskboot flag?

  62. Alex

    The boot flag only enables it to run software from the card; with a formatted card, it doesn't impact functionality in any way.

    You can try to use the camera without ML for a while.

    Could be related to heat; in movie mode the camera stresses the sensor more than in photo mode.

  63. Josh_carver reporter

    Testing without ML hasn't worked. Just taking photos with formatted card and no ml and it failed fairly quickly. Emailed a camera repair service and they gave me a quote for £120, but I'm not going to take it because they said they would repair the circuit/shutter assembly- I've already had the shutter inspected and it's fine. Could be a circuit problem I guess... but then it could just be software. So running out of ideas unless I can find someone local that I can trust to take a look at it.

    Though I'm not getting any warnings of any kind, if heat related, what would the heat be affecting? And why would it still work without card/on usb if it is heat related?

    Cheers

    Josh

  64. Log in to comment