550d exposure broken by HDR shooting. (Twice!) Sending camera to Canon AGAIN.

Issue #872 resolved
Former user created an issue

I have been using ML to shoot 7 and 9 bracketed sets for HDR photography. After doing this for a few weeks, my T2i developed a severe exposure problem when shooting through thew viewfinder. All shots were over exposed by 2+ stops. (Shots taken through LiveView use a different metering system and were perfect.)

I sent my camera in for servicing and it came back to me in perfect working order. Didn't use ML for some time out of fear it may have done something wonky to the camera firmware or settings.

Started using the 11.11.11 release of ML this weekend for more bracketed shooting and after one day out, my camera's exposure is suddenly "broken" again. This time, all viewfinder shots are underexposed by 2+ stops. I have removed ML completely, reflashed with standard 1.09 firmware, reset all settings, etc. Nothing helps. Sadly the T2i CMOS battery is inaccessible, otherwise I'd look at removing that as well for a COMPLETE reset of the camera.

I think the ML coders need to look into the serious possibility that something in the HDR bracketing is messing with the internal viewfinder exposure system.

Comments (36)

  1. Alex

    FYI: HDR bracketing works by changing shutter or exposure compensation, and taking pictures.

    Look at the exposure meter in manual mode, is it accurate?

    Are you sure ML was causing the problem?

  2. Former user Account Deleted

    Metering is correct in LiveView. Yet the exact same scene meters at +2 when taken through the viewfinder.

    I assure you, the problem has directly coincided with ML use in both cases.

    The exposure problem was gone after I got my camera back from Canon service center and did not re-appear until I used ML again.

    I understand correlation does not equal causation, but this is twice now that I had this specific problem directly after using ML for bracketed shooting.

    Not looking to point fingers, just trying to get my faithful companion working again.

  3. Alex

    Look at exposure meter in Manual mode, outside LiveView.

    In non-manual mode, is your exposure compensation set to zero?

  4. Former user Account Deleted

    Yes, EV is zeroed in non-manual mode. Checked that one right away.

    Viewfinder metering in any shooting mode reads as 2 stops too high. Thus, If I adjusted exposure according to the viewfinder metering, I'd end up with a shot 2 steps too dark.

    LiveView metering in any shooting mode reads accurate exposure. If I shoot with the settings metered in LiveView, the exposure is perfect.

    Is exposure compensation somehow "stuck" for the viewfinder mode?

  5. Former user Account Deleted

    Hey a1ex,

    I'm actually the same person who posted that issue to the T2i forum! :) Good recall on your part.

    I will realod MF and see if this results in a smaller misadjusted exposure. Stand by...

  6. Former user Account Deleted

    Tried 0.5 EV bracketing, tried 1.0 EV bracketing, even tried 0.0 EV bracketing. Sadly, the problem is exactly as before.

    LiveView = precise metering, good exposure Viewfinder = flawed metering results in image 2 stops underexposed.

  7. Alex

    What other functions did you use when the problem appeared?

    It's unlikely to be caused by bracketing, since this function was around for one year, and many people use it.

    Do you still have the problem with autofocus?

  8. Former user Account Deleted

    The only thing I activated was ML Bracketing (+some native EV during shooting.)

    That's the only thing I had changed after a fresh install of ML from 11.11.11

    I think at one point after discovering the problem I ran the shorter "Stress Test" in ML. That seemed to access and activate all sorts of functions. But, as I mentioned the exposure problem had already manifested at that point.

    That autofocus problem was solved by replacing the loose mirror. Canon checked and verified the shutter speed and exposure and all were well.

    Camera ran perfectly until this weekend when I installed ML. I'm not ruling out coincidence, or other causality, but it does seem less likely the second time in a row.

  9. Alex

    Can you run the procedure described in this post? https://bitbucket.org/hudson/magic-lantern/issue/752/550d-not-responding#comment-766685

    I want to compare your default settings with mine, to see the differences. It will simply read your current settings and save them to log files (no changes will be done to them).

    I also know a method for doing some sort of a factory reset, but it only seems to alter user settings (a bit more than "clear settings" in Canon menu, i.e. resetting date/time and changing menus in Japanese); I would only try that as a last resort.

  10. Former user Account Deleted

    I was just getting ready to pack the thing up and ship it off to Canon. I will generate a logfile for you before I do that.

    VERY curious to know the "factory reset" procedure as I was hoping something like that might solve my problem since there's no user accessible way to remove the CMOS battery on this model.

  11. heffstl

    Here are the two logfiles. I may have left a couple of custom functions set. (ISO expansion ON and Long Exposure Noise Reduction AUTO) And I think Illumination correction has been turned off. But hopefully that won't throw you off the trail.

    Do let me know about that factory reset routine if you can. Eager to try that before sending my baby out for repair.

    p.s. I'm signed into the bitbucket system now as heffstl, so no more anonymous postings.

  12. Alex

    Did you set the auto power off to a few minutes? The logs are not complete.

    Here is how the factory reset method works (and what we know about it): http://groups.google.com/group/ml-devel/browse_thread/thread/f813fe19f9c9813d/51b4518bf0a2278f?#51b4518bf0a2278f

    I'll tell you more shortly. If you are willing to give it a try (at your own risk, of course), you may also help us get a tiny bit of extra knowledge about it (i.e. to answer Indy's question from the second post).

  13. heffstl

    I will change the auto power-off to a few minutes and re-generate the log.

    Looked briefly at the factory reset thread but wasn't sure how to apply what was described there.

    New log coming shortly.

  14. heffstl

    Okay, here are the newly generated logs.

    I'm waiting to send the camera while we gather this data.

    Who knows, you may be able to save me from sending it at all if we can figure out what got tweaked.

  15. heffstl

    The problem is present with all of my Canon lenses.

    It only reads as manual lens right now because there's no lens on the camera in preparation for shipping back to Canon.

  16. Alex

    I didn't find anything suspicious in the logs, so here's the autoexec which resets to defaults. You run it at your own risk.

    So far it ran on 3 cameras, it did not solve any prolems or create new ones, but who knows. It does alter some settings which are not accessible in the menu (but they are probably unused; I did not notice any unusual change in my camera other than menu being in Japanese).

    When you hit "don't click me", it will run this code (tested on my 550D):

    	// save CAMSET00.DAT
    	msleep(2000);
    	call("SaveCamSetProp");
    	beep();
    
    	// factory reset
    	msleep(2000);
    	call("FA_SetDefaultSetting");
    	beep();
    
    	// save CAMSET01.DAT
    	msleep(2000);
    	call("SaveCamSetProp");
    	beep();
    

    Those functions are probably used by Canon service.

    The log files will only help us understand better what FA_SetDefaultSetting does (i.e. what settings restores).

  17. heffstl

    1) I Ran the Factory Reset autoexec and it did indeed reset the camera to factory defaults including Japanese menus. Thanks for reminding me how to get it back to english. Forgot that one.

    As you suspected, the reset did nothing to alleviate the exposure issue.

    After the reset, I noticed my shooter Copyright info had finally been reset by the process. (It was NOT reset when the camera came back from Canon service previously) making me doubt the same reset was done during the repair.

    2) I then loaded the LOG autoexec and ran the log again to get you fresh data on what values got reset. Those files are included with this post.

    Anything else I can do to gather data for you? Or is it time to ship this puppy out for a re-repair? (Which may in itself give us some clue if ML was implicated at all or if something else completely was at work.)

  18. Alex

    Probably it's a good idea to save a copy of the entire non-volatile memory area.

    Press "Don't click me", as usual. It will create a file named ROM.DAT (256 MB). This includes both ROM areas and some RAM.

    I have a question about how the firmware behaved during the day you had the problem. Did you have any situations when you had to take the battery out? Or crashes of any kind (err70)? (especially during bracketing)

  19. heffstl

    Okay, I'll dump the NVRAM and ROM for you using the autoexec.bin you provided. Thanks.

    Firmware behaved fine during shooting. No reboots, no crashes, no err70, no need to pull the battery.

  20. heffstl

    Here's the ROM file. (256Mb!) Have at it and let me know if there's anything else I can do at my end to help your process.

  21. heffstl

    Here's the ROM file. (256Mb!) Have at it and let me know if there's anything else I can do at my end to help your process.

  22. Alex

    Thanks, downloading. I don't need any more info for now.

    What I want is to compare the data before and after servicing, to be able to find the cause of the problem.

  23. heffstl

    UPDATE: My camera is back from Canon service with the following cryptic description.

    "Your product has been examined and it was found that the adjustment of the ae assembly was incorrect causing under-exposure. Electrical adjustments were carried out on the assembly. Product functions were confirmed."

    Anybody want to translate that into english for me? Is this a calibration thing with the Auto-Exposure system? What exactly do they mean by 'electrical adjustments'

    :)

  24. Former user Account Deleted

    More importantly, can we concluded therefore that ML is not implicated in any of the problems? Would like to go back to using it if at all possible.

  25. Alex

    Probably the exposure sensors were recalibrated.

    If you repeat the procedure which generated the PROP*.LOG and ROM.DAT files, I may be able to figure out where the calibration data is stored. That's a good thing to know, it may provide better understanding on how the firmware works.

    Given the number of downloads ( https://bitbucket.org/hudson/magic-lantern/downloads ) and that you are the only one with this issue, it's very possible that the problem was not caused by ML.

    Bracketing is one year old on 550D ML and it's one of the most used function for stills ( http://www.flickr.com/groups/magiclanternfirmware/ ).

    Also, on our development cameras, we often run potentially dangerous things which don't appear in main builds (things like entering factory menus, changing memory addresses just to understand what's going on etc). None of these actions resulted in permanent damage.

    http://groups.google.com/group/ml-devel/browse_thread/thread/648f25d8d543e58

  26. heffstl

    a1ex, thanks for taking the time to work with me on the issue. I'm sure you've got a million other bugs to hunt down, so I just want to acknowledge your efforts here. Particularly in a case like this where ML may turn out to have nothing to do with the problem.

    I will go ahead and dump the PROP*.LOG and ROM.DAT files for you. I still have the Autoexec you previously provided for use with the diagnostic process.

    Quick question...Should I use the same version of ML as before + the autoexec. Or should I use one of the more recent builds? Seems like it's only gotten better over time. But I wouldn't want to throw in an unwanted extra variable into the troubleshooting process if it makes a difference.

    best from STL,

    -Jeff

  27. Alex

    I'd recommend the latest version; while using it myself during Christmas holidays, I did not find any stability problem with it.

    And it was downloaded over 26.000 times, so it should be fine.

  28. Log in to comment