550d Wont Boot

Issue #911 on hold
manufan4eva created an issue

I accidently left my 550d on overnight, and now it wont boot. It works fine without a memory card, but as soon as i put one in, i get nothing but a blank screen. No flashing memory card access light, but i do get shutter/aperture and iso info in the viewfinder. It also autofocus' on half press of the shutter. Ive tried everything, ive even formatted and reinstalled all the magic lantern files, to no avail.

Any help?

Thanks

Comments (10)

  1. Former user Account Deleted

    If you have a bootable card and have the BOOTDISK flag set in the camera (which the installer does), and you do not have an AUTOEXEC.BIN file on the card the camera WILL NOT BOOT! It will hang and not wake up until the battery is removed.

  2. Alex

    This symptom appears when your card is bootable, but autoexec.bin is missing (or not recognized).

    http://freecode.com/articles/how-to-report-bugs-effectively

    When you say "I've tried everything" it's very ambiguous. It's simply not possible to do that.

    Is your battery charged? Does the camera boot with a brand new card? Before attempting to boot, did you take the battery out first?

    There was a user with a similar problem; he had a hardware problem with the card slot (one of the contacts was bent). The symptoms were the same (black screen, but autofocus working).

  3. manufan4eva reporter
    • changed status to open

    My battery is fully charged, ive tried my official and unofficial batteries. The card boots with no card inserted, but none at all with one inserted. Ive taken the battery out before attempting to boot, after attempting to boot, left it out for a few minutes and that didnt work. I tried putting updated/outdated ML files on my card and that hasnt worked either.

    Ive come to the conclusion as you said maybe its a hardware issue. Im going to try and get hold of a new card as i only currently have 1 sd card in my house, if that doesnt work, ill have to get the camera repaired.

    Thanks for your time.

  4. Alex

    Try with a SD card which you know is working (ask a friend who has a 550D).

    Bad SD cards can also cause this.

    With a ML card you should see the LED blinking as soon as you power it on. With a formatted card, blinking happens around one second later.

  5. Log in to comment