Cannot turn on 60D without Magic Lantern (on vanilla firmware)

Issue #939 resolved
Former user created an issue

I installed ML on my 60D a week ago. I am a still shooter and only need Magic Lantern when doing bracketing mostly, so I don't want to use it rest of the time. But I am not able to switch on the camera without loading Magic Lantern.

The user guide says under Misc shortcuts: "SET pressed at startup: loads vanilla firmware (does not load Magic Lantern)." But that is not working. I also tried pressing the shutter while starting up (both half-pressed and fully pressed) because a google search said that might work, but it didn't.

Am I doing something wrong or is this a bug?

Comments (8)

  1. stoecky

    I've using actual ML (22-12) and tested you problem on a 60D. If I press "SET" while powering on the Camera, ML is not loaded. I see a "fresh" Canon-Cam ;)

  2. Former user Account Deleted

    I have the same problem with my 60D. I just installed ML 2011Dec22 and am still exploring everything. However, I too cannot turn the camera on without ML. Pressing and holding the SET button while flipping the ON/OFF switch should do the trick, right?

    And another question: is it normal that the LED blinks every 5 seconds while the camera on?

  3. Former user Account Deleted

    OK, I know what the problem is. I've assigned the electronic level function to the SET button (C.Fn IV-2), and that is apparently preventing ML from detecting the button press. When I assign no function to the SET button, I can disable ML at startup.

  4. Former user Account Deleted

    Original poster here. @post #3, thank you for figuring that out. I had assigned Manual AF point selection to the SET button, and changing that setting did indeed fix the problem in a way. I can start the camera without Magic Lantern by pressing SET.

    However, even with Magic Lantern off, the LCD screen is always on. Previously, unless I am using live view, the LCD switched on only when pressing Q or Menu or Info buttons. But after installing ML, I cannot find a way to turn off the LCD (I want to use just the viewfinder).

  5. Former user Account Deleted

    Do you mean that you always have the "shooting functions" display on the back LCD?

    Pressing INFO should switch that off. Personally, I have removed the shooting functions from the INFO button display options, because I can use the Q button when I need to see (and change) them.

    Regarding the LED blinking: that is probably originating in clearscreen_task().

  6. Former user Account Deleted

    What if, before switching on, you just swap in a plain SD card without Magic Lantern files on it for those times you do not wish to use it?

  7. James Pittendreigh

    I'm having this issue as well, however it is with a different custom function "C.Fn III Autofocus/Drive Af point selection method": when this is set to option 1 instead of the default of 0, it removes the ability to remove ML from startup.

    Is there a way to change the button to press on startup/boot to disable magic lantern for a single session?

    I think I prefered the old way of using the shutter to disable ML on boot, as that was a bit more reliable and the custom functions didn't seem to get in the way (at least on my 60D anyway!) Thanks

  8. Log in to comment