HELP. Canon 60D not turn.

Issue #949 on hold
Former user created an issue

I updated the Magic Lantern in the wrong way and my Canon 60D does not want to call.

I went in and went on Canon Utilities Firmware Update and there select the archive "ml-60d-110.fir." After that appeared a message "ERR" on the upper display and so removed the battery and put again, the camera did not care anymore.

What do I do?? I'm desperate and will not turn on the camera.

I'm from Brazil, my name is Rafael...PLEASE PLEASE HELP!!!!

Comments (6)

  1. Alex

    You have installed ML via EOS Utility? I've never tried to do that, but I will.

    Try booting with a formatted card, or without a card (of course, after taking the battery out).

  2. Alex

    I've tried to install ML via EOS utility; got the message saying "memory card is required to update".

    Try this:

    • Prepare a card with ML files on it, and make it bootable with EosCard/MacBoot. To make sure you did it right, check the card in another camera (can be any other small camera supported by ML). Check for any signs of activity (LED blinking, messages in the viewfinder).
    • Format a card and place Canon's FIR file on it. Maybe the firmware is looking for a FIR file.

    I guess all the doors are properly closed and the battery is charged, right?

  3. Former user Account Deleted

    Is OK with the card and read on another camera. Insert a file. FIR and life goes on without the camera. No power and shows no sign of life. I sent for service, I had no solution.

  4. Log in to comment