Play mode: cannot zoom in a picture

Issue #954 resolved
Michal Fapso created an issue

When I preview a photo and press the zoom in button, nothing happens (the photo should zoom in). This problem appears on 600D in ML version from 22nd December. The previous version from 12th December works fine.

Comments (34)

  1. Former user Account Deleted

    Update: Working for me again after: (- Doing the stability test) - Turn Global Draw on - Try to zoom in playmode - Turn Global Draw off ---> should still work

  2. Michal Fapso reporter

    Hi Alex, it doesn't seem to be intermittent at least for my camera.

    I tried to put back the autoexec.bin from 22nd Dec. and the picture zoom did not work again. I also turned off the camera, removed and inserted the battery, turn it on again, but it did not help. Tried that 3 times, always with the same result.

    I didn't try the stability test, but the simple "Turn Global Draw on - Try to zoom in playmode - Turn Global Draw off" did not help.

  3. Former user Account Deleted

    I have the same issue on my 600d/t3i. I put in an earlier bug #950 about this, but has yet to be looked at. The earlier build works fine. It is the latest build that does not work. I have since gone back to the earlier build until this bug is fixed.

  4. Alex

    When I ask other 600D users about this, it works fine for them. So it's probably triggered by some particular setting. Can you find it?

  5. Michal Fapso reporter

    Thanks a lot for the working configs. Most of the settings were same in mine and at least one of the working configs. Few settings were different, so I tried to change them according the working configs, but it did not work for me. However, I didn't try all the different settings.

    Finally I removed mine MAGIC.CFG from the card and when I started the camera, picture zooming suddenly worked!

    Thanks for your help.

  6. papaez

    Once I removed the magic.cfg which just basically brings it back to default. But once I set things up again it happened. The component that is the source of the problem is LiveView -> Magic Zoom. If this enabled in this build the zoom in play mode does not work. Once I disabled it, it was working again.

  7. Michal Fapso reporter

    You are right, papaez. The Magic Zoom causes it. And it happens in all trigger modes (Video, M, Av, Tv, A+, ...).

    Once I triggered the Video mode, almost instantly pushed the play button and the zoom in button and the picture zoomed in only one step, but then it didn't work again. Don't know if that is a helpful information for Alex or not.

  8. Alex

    What's odd is that I can't explain this behavior by looking at the source code. The zoom key is not blocked by Magic Zoom if the LiveView is inactive.

    Anyway... have some playing with the bleeding edge.

  9. Michal Fapso reporter

    Great work, Alex! It works now with the new autoexec.bin! I turned on the Magic Zoom and can zoom in a photo as well. Thanks a lot!

  10. Michal Fapso reporter

    Maybe it was a side-effect of something else that changed between the Xmas version and the current one. I hope it will be confirmed by others too.

  11. Former user Account Deleted

    Sorry for my ignorance, (am facing this issue as well) but what do you do with that autoexc.bin file that alex attached? Do you paste it somewhere or replace another file..? haha. ok thanks xD

  12. Former user Account Deleted

    Hi im the same anonymous guy above (habez) and i copied the attached autoexe bin thingy and pasted it into the memory card and replaced the old now and like everyone says, it works perfectly now. (:

    Thanks for the miracle cure! :D

  13. Michal Fapso reporter

    Anonymous -> you just have to copy the autoexec.bin to your SD card's root directory. If you already installed Magic Lantern on that card, you should have autoexec.bin already there. Just replace it with the file sent by Alex.

  14. Former user Account Deleted

    Anon, make sure you don't have the zoom mode set to FAST+100%. That setting is supposed to zoom to the max with the first press of the zoom button.

  15. Former user Account Deleted

    Is this issue finally resolved? When Zoom in (*) mode is used for magic zoom and I switch from the live view to play mode by pressing the |> key, the zoom in key is no longer working. I believe magic zoom still block the zoom in key in this case for the stable release. Anyway, I would not use the bleeding edge files to dare my camera from my wife and have to wait for your next release.

  16. BBDragon

    Obviously the autoexec.bin above is not the same then the one in the latest version of ML (big difference of size).

    I had the same issue with the zoom-in not working anymore (after it worked initially) on a 600D. I can also confirm that it was linked with the setting of the magic zoom: being on no zoom-in anymore, being off zoom-in working as it should.

    Then I replaced the original autoexec.bin with the one above and now the magic zoom is not working anymore but the zoom-in is ok. (Besides also I think that the layout of the menu has changed due to the replacement of the autoexec.bin file.)

    So I think this issue is still not resolved since both functions magic zoom and zoom in play mode do not work together but either one or the other.

  17. BBDragon

    Never mind my both my last paragraphs above. I had to trigger the magic zoom by pressing the zoom button which seems to be perfectly normal. So this issue seems to be resolved!!

  18. Former user Account Deleted

    Great work to fix this rather annoying bug. Why not replace the ML autoexec.bin by the corrected one in ML package ?

    Thanks again. John

  19. Former user Account Deleted

    Hi, I have just used the fixed autoexec.bin and the problem is resolved - thanks! I am curious as to why the file is so much smaller than the one in the 22Dec 2011 package, is there anything taken out?

  20. Former user Account Deleted

    The replacing the autoexec.bin file allows you to zoom into photos during playback, however, it brings back the issue of having the "magic zoom" window flicker. It seems you can only have one or the other? Working zoom or flicker free magic zoom.

  21. Log in to comment