Cannot install the latest version (Dec 22) on 60d.

Issue #964 resolved
Former user created an issue

Card LED blinks continuously after running Firmware Upgrade. I have the correct firmware 1.1.0 but following the instructions in #Troubleshooting I reloaded the 1.1.0 firmware successfully and tried again. Same thing happens. I also tried redownload the zip file, my md5 hash is d590f7cbf09bbcf14fd2135681e9a707 in both cases.

Thanks if you can look into it!

Comments (14)

  1. Alex

    Did you reload the 1.1.0 from the link provided by ML guide?

    Can you send me the Canon 1.1.0 FIR you have used for upgrade? (attach it here)

  2. Former user Account Deleted

    Thanks. Indeed the new files produce different MD5 hashes, I will test them as soon as I get home. For reference, I include MD5 for the originally downloaded files (downloaded twice to check that it is repeatable), and yours.

    Original md5's:

    bash-3.2$ md5sum ml-60d-110.fir 8f604b4bd3d5eebb01a02756c96bbf74 ml-60d-110.fir

    bash-3.2$ md5sum autoexec.bin 954b6f16db2000b0708eb4f773de75a1 autoexec.bin

    New ones I just downloaded from here

    bash-3.2$ cd Documents/software/cine/test/a1ex/

    bash-3.2$ md5sum ml-60d-110.fir 611061137e1d48d7d45ca0581becca0a ml-60d-110.fir

    bash-3.2$ md5sum autoexec.bin eb1dc0be58edff03ea8e7711bc5c41fd autoexec.bin

  3. Former user Account Deleted

    Using your autexec.bin and .fir file made installation go through. (Although the green screen in the end had some flashing numbers on it, so it might have been anomalous)

    After rebooting the camera, it shows

    err 70

    even though it focuses and takes pictures (but the screen is black). Tried reformatting the card, and recopying the data, then making it bootable with macboot, same results. Just for fun, I tried the original files (md5 ending with bf74 and 75a1), in that case, even without turning the camera on, the led is fleshing, and nothing happens. Recopying your two files, again results with err 70.

    the camera appears normal with non-ML memory card, or if I reformat this card (I tried installing ML twice with the exact same results).

    thanks for any help.

  4. Alex

    Hm... this sounds like your firmware is different than what ML expects.

    The big autoexec computes a checksum of Canon firmware (their executable code) and from this checksum it identifies the camera.

    Run the attached FIR; it's the normal installer, without firmware version check, and it saves a copy of Canon firmware in ROM0.BIN. Send this file to me by e-mail (don't attach it here).

  5. Former user Account Deleted

    Interesting, since I definitely ``updated'' despite that the version number was 110 even before... I sent the memory dump to a1ex@bitbucket.org (hopefully that's correct?). Thanks!

  6. Former user Account Deleted

    I need another hint, because I have no idea what I should look up in the ML manual :) As far as I know I did everything according to the ML instruction, and I upgraded successfully the canon .fir, as well as the .fir's you sent. ?

  7. Former user Account Deleted

    Since I have no idea what you're talking about, I decided to wait for the next version. Thank you for your effort though, I understand if people don't want to spend time with hand holding...

  8. Alex

    On the first page in ML manual, it says "contact me via e-mail". Also, ML versions are announced on a mailing list. So I don't get what's so difficult.

  9. Former user Account Deleted

    Hi I am having the same issue with my t2i I cant load the Dec 22 release. It just keeps showing the red led light and thats it.

  10. Log in to comment