No such file or directory when running rsync

Issue #14 resolved
Nate Aune
created an issue

When I run the command: {{{ $ silver setup-node myhost }}} I get the following error:

{{{

!python

Processing triggers for python-support ... Traceback (most recent call last): File "/srv/silverlining/bin/silver", line 9, in <module> load_entry_point('SilverLining==0.1dev', 'console_scripts', 'silver')() File "/srv/silverlining/src/silverlining/silverlining/runner.py", line 414, in decorated return func(args, *kw) File "/srv/silverlining/src/silverlining/silverlining/runner.py", line 447, in main return func(config) File "/srv/silverlining/src/silverlining/silverlining/commands/setup_node.py", line 108, in command_setup_node setup_rsync(config, 'server-root/', '/') File "/srv/silverlining/src/silverlining/silverlining/commands/setup_node.py", line 15, in setup_rsync cwd=cwd) File "/srv/silverlining/src/silverlining/silversupport/shell.py", line 66, in run ' '.join(conditional_shell_escape(i) for i in command), e)) OSError: Error while running command "rsync --quiet -prvC server-root/ 'root@myhost:/'": [Errno 2] No such file or directory

}}}

Comments (2)

  1. Ian Bicking repo owner

    I'm not sure what's going on here. How did you install? I tested installing from source (usually I run from the checkout) and it also seems fine (server-root is copied over). What files do you have where silverlining is run.

  2. Nate Aune reporter

    The problem was really silly. Apparently, the stock Ubuntu Lucid Lynx provided by Rackspace didn't have rsync installed. The error message wasn't very obvious that this was missing. Once I installed rsync with apt-get install rsync then the setup-node command executed without error.

  3. Log in to comment