Commits

Iñigo Serna  committed 668f91e

Released version 2.2

* README: Released version 2.2
* README.pyview:
* NEWS:

* README: requires python 2.4 or up
* lfm/lfm:
* lfm/pyview:

  • Participants
  • Parent commits 9bf0550
  • Tags v2.2

Comments (0)

Files changed (8)

+Sat May 22 11:23:21 2010  Iñigo Serna  <inigoserna@gmail.com>
+
+	* README: Released version 2.2
+	* README.pyview:
+	* NEWS:
+
+Sat May 22 11:21:01 2010  Iñigo Serna  <inigoserna@gmail.com>
+
+	* README: requires python 2.4 or up
+	* lfm/lfm:
+	* lfm/pyview:
+
 Fri May 21 23:20:19 2010  Iñigo Serna  <inigoserna@gmail.com>
 
 	* lfm/__init__.py (sysprogs): added xz
-Version 2.2 ("Approaching perfection") - 2010/01/xx:
+Version 2.2 ("Approaching perfection") - 2010/05/22:
 
   + New features
     - use 2 progress bars in copy/move/delete dialog, one for files count
 
 :Author: Iñigo Serna, inigoserna AT gmail DOT com
 
-:Version: 2.2, May xxth. 2010
+:Version: 2.2, May 22th. 2010
 
 =========================================================
 :Home page: http://www.terra.es/personal7/inigoserna/lfm/
 
           There is NO WARRANTY.
 
-:Last update: Fri May 21 23:21:03 2010
+:Last update: Sat May 22 11:18:05 2010
 
 .. contents:: Table of Contents
 
 Requirements
 ============
 *Lfm* and *Pyview* are written in Python_ and require curses module.
-It should run on Python v2.3 or higher, as but I'm only have v2.6 on my
+It should run on Python v2.4 or higher, as but I'm only have v2.6 on my
 computers I haven't tested older versions.
 
 All modern UNIX flavours (Linux, \*BSD, Solaris, etc) should run it without 
    +---------+------------------+------------+
    | Version |       File       |    Date    |
    +=========+==================+============+
-   |   2.2   | lfm-2.2.tar.gz_  | 2010/01/xx |
+   |   2.2   | lfm-2.2.tar.gz_  | 2010/05/22 |
    +---------+------------------+------------+
    |   2.1   | lfm-2.1.tar.gz_  | 2008/12/21 |
    +---------+------------------+------------+

File README.pyview

 
 :Author: I�igo Serna, inigoserna AT gmail DOT com
 
-:Version: 2.2, January xxth. 2010
+:Version: 2.2, May 22th. 2010
 
 :Home page: http://www.terra.es/personal7/inigoserna/lfm/
 
 
           There is NO WARRANTY.
 
-:Last update: Sat Jan 23 21:09:30 2010
+:Last update: Sat May 22 11:18:35 2010
 
 .. contents:: Table of Contents
 
 ============================================================================
-Last update:	Time-stamp: <2010-05-21 23:24:41 inigo>
+Last update:	Time-stamp: <2010-05-22 11:26:41 inigo>
 ============================================================================
 
 General:
 ========
 
-- diff between xxx.orig and xxx
-- curses.set
-
-
-New release:
-  + README, README.pyview, NEWS:
-    - fix dates and version
-  + TODO
-    - clean
-  + udpate web:
-    - contents, add new files
-    - katxi, terra, googlecode
-  + announce: python*, freshmeat, pypi, fsf, debian, aur
-
-
 Bugs:
-- speed up cursor movement => curses.panel
-- don't like much recursive chmod/chown/chgrp as currently works
-  . split in 2 different features chmod and chown/chgrp ?
-
 
 Medium Priority:
+  + improvements
+1   - don't like much recursive chmod/chown/chgrp as currently works
+      . split in 2 different features chmod and chown/chgrp ?
   + ui
 1   - support for languages with wide chars
       . check the real length on screen of the utf8-encoded strings
       . customized: permissions instead of date
       . quick view
       . info view
+    - speed up cursor movement => curses.panel
   + new features:
 2   - command line
       . loop over selected files
       . flag: show output & errors or only errors
       . options: flag save historic between sessions, number of items to save
     - crypt files
-    - sync dirs, use filecmp.dircmp
+3   - sync dirs, use filecmp.dircmp
+3   - diff between xxx.orig and xxx => Plugins in F11?
     - pyinotify
 
 Low Priority (maybe some day):
 # -*- coding: utf-8 -*-
 
 # Copyright (C) 2001-10  Iñigo Serna
-# Time-stamp: <2010-01-23 21:11:37 inigo>
+# Time-stamp: <2010-05-22 11:22:27 inigo>
 #
 # This program is free software: you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
 import sys
 from lfm.lfm import lfm_start
 
-if sys.version_info < (2, 3):
-    print "Python 2.3 or higher is required to run lfm."
+if sys.version_info < (2, 4):
+    print "Python 2.4 or higher is required to run lfm."
 else:
     lfm_start(sys.argv)
 # -*- coding: utf-8 -*-
 
 # Copyright (C) 2001-10  Iñigo Serna
-# Time-stamp: <2010-01-23 21:11:14 inigo>
+# Time-stamp: <2010-05-22 11:22:17 inigo>
 #
 # This program is free software: you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
 import sys
 from lfm.pyview import PyView
 
-if sys.version_info < (2, 3):
-    print "Python 2.3 or higher is required to run pyview."
+if sys.version_info < (2, 4):
+    print "Python 2.4 or higher is required to run pyview."
 else:
     PyView(sys.argv)

File lfm/pyview.py

 Though  initially it was written to be used with 'lfm',
 it can be used standalone too.
 Since version 0.9 it can read from standard input too
-(eg. $ ps efax | pyview)
+(eg. $ ps efax | pyview  -s)
 
 This software has been realised under the GPL License,
 see the COPYING file that comes with this package.