python33.dll missing

Create issue
Issue #38 closed
florian mauch created an issue

Hi, I just ran the latest AllInOne-installer. When starting itom afterwards an error appears, saying that python33.dll cannot be found. When looking into the python-folder, that was just created, I can see a python3.dll but no python33.dll.

Any ideas?

Comments (4)

  1. florian mauch reporter

    never mind. I found the python33.dll in the base folder of python. However, I had to add that path to the system path variable manually.

    Now it works

  2. M. Gronle

    Usually, the setup of python copies the library python34.dll (or similar) into Windows/System32 or Windows/SysWOW64 (for 32bit python under 64bit Windows). This is the directory where itom tries to get the python library from. Manually adding other directories is allowed, too. Can you check, if you have the library file in one of windows system directories? Maybe, you installed Python with insufficient rights such that the copying failed. This would be worth to know in order to adapt the documentation or setups.

    Cheers Marc

  3. florian mauch reporter

    Hi Marc,

    I can't find the dll in the system folder you mention. It's quite possible that I ran the setup with no administration rights. I have to activate them manually each time I need them on my machine. I can't tell for sure though...

  4. Log in to comment