Issue #141 resolved

Hosting scheme not compatible with latest pip

Tomas Neme
created an issue

The latest pip requires a bunch of special flags for projects not hosted in pypi, that are not served through https or somehow verified.

Please either update your build process to upload the builds to pypi as well as the version tags, or use the https bitbucket url as an external

(I think just changing http to https in this line https://bitbucket.org/izi/django-admin-tools/src/50fd97a834d86a54befc59e7cb24fe3a5e60ccd1/setup.py?at=default#cl-6 would do the trick)

Comments (6)

  1. Tai Lee

    Yep. The docs say pip install django-admin-tools, but that doesn't work. Even --allow-all-external doesn't work. You need --allow-unverified django-admin-tools.

  2. Ivan Anishchuk

    Doesn't work for me anymore. Pip version 1.5.4:

    $ pip install django-admin-tools==0.5.1
    Downloading/unpacking django-admin-tools==0.5.1
      Could not find a version that satisfies the requirement django-admin-tools==0.5.1 (from versions: 0.4.0)
      Some externally hosted files were ignored (use --allow-external to allow).
    Cleaning up...
    No distributions matching the version for django-admin-tools==0.5.1
    Storing debug log for failure in /home/user/.pip/pip.log
    $ pip install --allow-unverified django-admin-tools==0.5.1
    You must give at least one requirement to install (see "pip help install")
    
  3. Log in to comment