Issue #42 resolved

Please release on pypi

Rémy HUBSCHER
created an issue

Please make a python sdist upload so that we've got the packet on pypi and we can add it automatically to our mirror.

Comments (18)

  1. David Jean Louis repo owner

    Sorry but I stopped using pypi for file hosting, it's too unreliable. I never had a single problem with bitbucket. I understand the mirror problem but I'm really -1 on switching to pypi.

  2. David Jean Louis repo owner

    I'm not sure, if I release on both, won't the pypi file take precedence for package managers like pip or easy_install ? It also complicates the release process and confuses users (which one should I download ?)... Can't you find a solution on your side ?

  3. David Jean Louis repo owner

    True, but believe me I have bad memories on pypi file hosting (not necessary pypi being down, but downloads slow as hell or just timeouts), maybe it has changed though, I don't know... So far, bitbucket served nearly a million downloads of polib with no hassle, I'm sticking with it for now.

  4. Rémy HUBSCHER reporter

    I wish to reopen this issue because since pip 1.5, polib version after 0.3.1 are not find by default.

    We have to add the --allow-external option. It would be really nice to you to release on pypi.

    pypi hosting changed, they now have a CDN.

    Thank you.

  5. Rémy HUBSCHER reporter

    I've got another problem today:

    Error The read operation timed out while getting 
    http://bitbucket.org/izi/polib/downloads/polib-1.0.3.tar.gz
    (from https://pypi.python.org/simple/polib/)
    
  6. Log in to comment