1. jacobmason
  2. sphinx-web-support

Commits

DasIch  committed face295

Use uuid as a requirement in the setup.py and mention it in the documentation for Python 2.4

  • Participants
  • Parent commits 78fb471
  • Branches default

Comments (0)

Files changed (2)

File doc/intro.rst

View file
  • Ignore whitespace
 or some (not broken) SVN trunk snapshot.  If you like to have source code
 highlighting support, you must also install the Pygments_ library.
 
+If you use **Python 2.4** you also need uuid_.
+
 .. _reStructuredText: http://docutils.sf.net/rst.html
 .. _docutils: http://docutils.sf.net/
 .. _Jinja2: http://jinja.pocoo.org/2/
 .. _Pygments: http://pygments.org/
+.. The given homepage is only a directory listing so I'm using the pypi site.
+.. _uuid: http://pypi.python.org/pypi/uuid/
 
 
 Usage

File setup.py

View file
  • Ignore whitespace
 <http://bitbucket.org/birkenfeld/sphinx/get/tip.gz#egg=Sphinx-dev>`_.
 '''
 
-requires = ['Pygments>=0.8', 'Jinja2>=2.2', 'docutils>=0.5']
+requires = ['Pygments>=0.8', 'Jinja2>=2.2', 'docutils>=0.5', 'uuid>=1.30']
 
 if sys.version_info < (2, 4):
     print('ERROR: Sphinx requires at least Python 2.4 to run.')
     except:
         pass
     else:
-        del requires[-1]
+        del requires[-2]
+elif sys.version_info >= (2, 5):
+    # An uuid module has been added to the stdlib in 2.5
+    del requires[-1]
 
 
 # Provide a "compile_catalog" command that also creates the translated