Commits

Ronald Oussoren committed 8922049

- Include a reference to our website in the ReadMe inside the installer
- Include a reference to our website in the documentation index
- The InstallationCheck messages were not shown on non-Jaguar systems,
due to a buglet: message numbers must be between 16 and 31, others are
reserved by Apple.

Comments (0)

Files changed (4)

pyobjc/Doc/index.txt

 Python scripts that use and extend existing Objective-C class libraries,
 most importantly the `Cocoa libraries`_ by `Apple`_.
 
+More information can be found on `our website <http://pyobjc.sf.net>`_
+
 .. _`Apple`: http://www.apple.com/
 
 .. _`Cocoa libraries`:  http://developer.apple.com/techpubs/macosx/Cocoa/CocoaTopics.html 
 
+.. _`our website <http://pyobjc.sf.net>`: http://pyobjc.sf.net/
+
 General user documentation
 ..........................
 

pyobjc/Installer Package/ReadMe.txt

 Foundation and AppKit. These modules not only give you access to the classes in
 these frameworks but also to the functions and constants in those modules.
 
+More information on PyObjC can be found on 
+`our website <http://pyobjc.sf.net>`_.
+
+.. _`our website <http://pyobjc.sf.net>`: http://pyobjc.sf.net/
+
 To install this package double-click on ``PyObjC.pkg``. This will install the
 PyObjC python package and some Project Builder templates. The documentation
 and examples are found in  the folder ``PyObjC Documentation and Examples``. 

pyobjc/Installer Package/Resources/English.lproj/InstallationCheck.strings

-"1" = "Your system is too old, need at least MacOS X 10.2 too install";
-"2" = "Your system is too new, need a MacOS X 10.2.x system too install";
+"16" = "Your system is too old, need at least MacOS X 10.2 too install";
+"17" = "Your system is too new, need a MacOS X 10.2.x system too install";

pyobjc/Installer Package/Resources/InstallationCheck

 #!/bin/sh
 
-FAIL=96
-MSG_TOO_OLD=1	# Pre-Jaguar
-MSG_TOO_NEW=2	# Post-Jaguar
+FAIL=9
+
+# Msg numbers *must* be 16 and 31.
+MSG_TOO_OLD=16	# Pre-Jaguar
+MSG_TOO_NEW=17	# Post-Jaguar
 
 if [ -d /usr/bin/sw_vers ]; then
 	VER=`/usr/bin/sw_vers | grep ProductVersion: | awk '{ print $2 }'`