Weird behaviour of SemigroupIdeal (?)

Issue #127 resolved
Markus Pfeiffer
created an issue

I just tried creating some ideals of matrix semigroups like so:

gap> S := RandomMatrixSemigroup(GF(4), 2, 4, [1,2]);
<monoid of 4x4 s-matrices over GF(2^2) with 2 generators>
gap> Size(S);
21
gap> I := SemigroupIdeal(S, Idempotents(S));
<ideal of semigroup of 4x4 s-matrices over GF(2^2) with 8 generators>
gap> Size(I);
57

This strikes me as rather odd, so I thought it's a problem with the matrix code, but the transformations code behaves the same:

gap> T := AsTransformationSemigroup(S);
<transformation monoid on 256 pts with 2 generators>
gap> Size(T);
21
gap> I := SemigroupIdeal(T, Idempotents(T));
<regular transformation semigroup ideal on 256 pts with 8 generators>
gap> Size(I);
57

The generators for the matrix semigroup are the following:

[ NewSMatrix(IsPlistSMatrixRep, GF(2^2), 4, [ [ Z(2)^0, 0*Z(2), 0*Z(2), 0*Z(2) ], 
      [ 0*Z(2), Z(2)^0, 0*Z(2), 0*Z(2) ], [ 0*Z(2), 0*Z(2), Z(2)^0, 0*Z(2) ], 
      [ 0*Z(2), 0*Z(2), 0*Z(2), Z(2)^0 ] ]), NewSMatrix(IsPlistSMatrixRep, GF(2^2), 4, 
    [ [ Z(2^2), Z(2)^0, Z(2^2), Z(2)^0 ], [ Z(2^2)^2, Z(2^2), Z(2^2)^2, Z(2^2) ], 
      [ Z(2)^0, Z(2^2)^2, Z(2)^0, Z(2^2)^2 ], [ Z(2)^0, Z(2^2)^2, Z(2)^0, Z(2^2)^2 ] ]), 
  NewSMatrix(IsPlistSMatrixRep, GF(2^2), 4, [ [ 0*Z(2), Z(2^2)^2, 0*Z(2), Z(2)^0 ], 
      [ Z(2^2)^2, Z(2)^0, 0*Z(2), Z(2)^0 ], [ Z(2^2), Z(2)^0, 0*Z(2), 0*Z(2) ], 
      [ Z(2^2)^2, Z(2)^0, 0*Z(2), Z(2)^0 ] ]) ]

Sorry if this is a known issue on the main branch, I didn't dare merging yet.

Comments (8)

  1. James Mitchell repo owner

    This exists in other branches too, I wasn't aware of it. Something is wrong in the main algorithm for regular acting semigroup ideals. I will investigate and update.

  2. James Mitchell repo owner

    I fixed it, and I grafted the changes onto the tip of matrix-semigroups (so you don't have to merge to get it). Please let me know if something still doesn't work.

  3. Log in to comment