Issue #19 open

Ubuntu 11.10 support

Anonymous created an issue

Although it is still a while before Ubuntu 11.10 is released, I thought the earlier we start to look at supporting it, the better.

I installed the latest .deb of Pynetkey on a fully updated 11.10 alpha install. When I run it, the login dialog is displayed with the Gtk-WARNINGs as below. When I say "connect" I get the error about importing the "gnome" module:

{{{ jpm@ubuntu:/usr/share/pyshared/pynetkey$ ./pynetkey.py

(pynetkey.py:2034): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(pynetkey.py:2034): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(pynetkey.py:2034): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(pynetkey.py:2034): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap", Traceback (most recent call last): File "./pynetkey.py", line 748, in <module> main() File "./pynetkey.py", line 743, in main inetkey.run() File "./pynetkey.py", line 497, in run import gnome ImportError: No module named gnome jpm@ubuntu:/usr/share/pyshared/pynetkey$ }}}

Comments (2)

  1. Janto Dreijer repo owner
    • changed status to open

    Thanks for checking!

    The ImportError is due to missing gnome bindings. It is used to capture gnome logout events so a firewall close can be triggered. It is not yet clear to me how this event can be captured in 11.10. For now, simply disabling that part (if gnome can't be imported) should be ok. See 3f1d342c547e for the change.

    The warnings can probably be fixed by installing something like gtk-engines-pixmap, but I haven't checked, and I don't think that's the right way to fix it. In any case, it doesn't look like pynetkey's behaviour is effected.

    I quickly ran into a bunch of ubuntu 11.10 alpha bugs. xdg-open doesn't work, for example. And the software center crashes quite easily. I suggest we wait for the beta before making any major changes, but bug reports are very welcome!

  2. Janto Dreijer repo owner

    These are now separate issues

    Related to the ImportError there is

    • #20 auto-close on desktop logout on unity

    The warnings are adressed in

    • #21 Unable to locate theme engine in module_path: "pixmap"

    which requires

    • #22 create PNG icons from SVGs
  3. Log in to comment