Issue #18 resolved

Problem with Ubuntu 11.04 and Unity desktop manager

Anonymous created an issue

When pynetkey is run in Ubuntu 11.04 (with the new Unity desktop manager), it no longer minimises to the 'system tray' but just disappears after connecting.

It is then impossible to disconnect it, and even ending all python processes in the System Monitor didn't seem to disconnect it.

I'm not sure if this is a general problem with Unity or if it is specific to pynetkey, so I'm sorry if it's the former.


Comments (5)

  1. Janto Dreijer repo owner

    It's not pynetkey specific. For very silly reasons 11.04 enforces a whitelist to decide which applications may go in the tray. You might have noticed other applications that are missing from the tray. I haven't tested it myself, but a workaround is available at You might also want to look at

    Let me know if it works, then I'll include it with the pynetkey install.

  2. Anonymous

    Just tried all four methods in the above links. None seem to work... Reading the comments it seems quite pynetkey isn't the only program for which they don't work. (I haven't actually installed 11.04, just running it off a USB stick at the moment, but don't think that would make a difference.)

    The only other thing I can think of is that I needed to run pynetkey in the first place to get online to get those commands and scripts, and then maybe because it was already running the changes couldn't happen? (I did start more instances obviously...)

    Anyways, I'll have a better try tomorrow and maybe I can get it to work. Otherwise it seems Ubuntu wants to force everyone to use their appindicator system. (Which I know nothing about.) Or is there an easy way to just make it minimise to the new Unity Launcher strip like a normal program? Except then you lose all the right-click functionality...

  3. Anonymous

    Tried again more carefully and got the same result... Seems I'll have to stick with Gnome until Ubuntu gets its act together.

  4. Log in to comment