Source

python-ldap / INSTALL

Full commit
------------------------------
Installing python-ldap
------------------------------

Prerequisites:

  Required:

    - Python 2.0 or newer (see http://www.python.org)

    - OpenLDAP libs (see http://www.openldap.org)
      You need OpenLDAP 2.1.3 client libs or newer for full
      functionality. It is possible to build with OpenLDAP 2.0.x
      client libs but some features are missing.

  Optional:

    - Cyrus SASL 2.1.x or newer (see )

    - OpenSSL 0.9.6 or newer (see http://www.openssl.org)

Quick build instructions:
    edit setup.cfg (see Build/ for platform-specific examples)
    python setup.py build
    python setup.py install

$Id$