Overview

OSSEC Web UI v0.8
Copyright (c) 2006-2013 Trend Micro Inc.


1- How to install.

1.0 - Prerequisites

    - Apache with PHP (>= 4.1 or >= 5.0) installed.
    - OSSEC (version >= 0.9-3) already installed.


1.1- Download the web ui package:

    # wget http://www.ossec.net/files/ui/ossec-wui-0.3.tar.gz


1.2- Decompress/untar and move the files to somewhere acessible by
     your web server:

    # tar -zxvf ossec-wui-0.3.tar.gz
    # mv ossec-wui* /var/www/htdocs/ossec-wui


1.3- Run the setup script (assign username/password...):

    # cd /var/www/htdocs/ossec-wui
    # ./setup.sh
    ...


1.4- Add your web server user (apache, www-data or nobody) to the ossec group:

    # vi /etc/group
    ..
    From:
        ossec:x:1002:
    To (if your web server user is www-data):
        ossec:x:1002:www-data

1.5- Fix the permissions for the tmp directory of your OSSEC installation (e.g., /var/ossec/tmp) and restart Apache

    # chmod 770 tmp/
    # chgrp www-data tmp/
    # apachectl restart


1.5- If you have a large ossec install, you may want to
     re-configure PHP to support longer lasting scripts
     and higher memory utilization. The following entries
     on php.ini can be increased:

     max_execution_time = 180
     max_input_time = 180
     memory_limit = 30M


1.6- Try to access the UI.

     http ://anyhost/ossec-wui/

1.7- Report any problems or suggestions to our mailing list.


#EOF