Clicking customize results causing trouble...

Create issue
Issue #2 resolved
Marko Käning created an issue

... since the customize dialog would not disappear when clicking "done" button

I saw your announcement of MacHg on hg's mailing list and just started to test it a little.

First of all I want to say that I am impressed by its looks. :)

Well, I used Murky for a while, but will give MacHg a go from time to time to help improving it, if I find enough time to post my issues here.

Good luck with this project of yours Jason!


Comments (7)

  1. Jason Harris repo owner

    I am not sure what you are talking about with respect to the customization? Can you send me a screen shot and a detailed description so I can fix it for future releases?

  2. Marko Käning reporter

    I marked this as resolved before, since I found this was no problem in the MacHg+hg1.5.2 version anymore, but well, I'll attach an image of what I meant.

    (And, funnily enough, now that I tried it a second time the error did not occur. Pressing the DONE button now lets the customization dialog disappear, which DEFINITELY wasn't the case before - otherwise I wouldn't have posted it.)

    Sorry for the inconvenience.

  3. Jason Harris repo owner
    • changed status to open

    Darn! I believe you that there was a bug! Can you delete your .hgrc file or move it aside and try to reproduce the problem? Also deleting your MacHg preferences and support might help:

    /Users/<yourname>/Library/Application Support/MacHg/

    It would be nice to reproduce this since other users will likely encounter it as well. Thanks for the help!

  4. Marko Käning reporter
    /Users/<yourname>/Library/Application Support/MacHg/

    The first didn't exist. The second did. So, I deleted it.

    I can't believe that it is the .hg file which could cause it. There is no relation to the toolbar customization whatsoever...

    But I tried anyway. To no avail. Error not reproducable.

    But, to tell you the truth: now that I think of it, I do often noticed with OS X 10.6 Snow Leopard that a newly installed program behaves differently after its first start and shutdown. Looks like some settings are being made within the system during the first run, which affect its general functionality. MacHg wouldn't be the first one. SimplyBurns I recall behaved also in a very strange manner on its first execution.

  5. Jason Harris repo owner

    Thanks for trying to reproduce this! So it was something to do with the toolbar customization?

    (There is a dialog which first comes up if you haven't entered a user name into your .hgrc file telling you basically give me a user name to use. I thought you were referring to this.)

    If anyone else can reproduce this on first install, send me a screen shot!

    Thanks all.

    Cheers, Jas

  6. Log in to comment