P3D3:: 0.9.15 appears to break push/pull, incoming/outgoing to SVN server

Issue #205 resolved
Former user created an issue

I installed the 0.9.15 yesterday and cloned a local repository. The original repo is also an SVN repository. Today I synced some changes via SVN and committed them to the original HG repo. The clone did not show the incoming/outgoing markers in the left-hand panel. Pulling fetched nothing. Pulling from the command line worked.

Sorry, I know that's a bit vague! I have no further insights into what's going on there.

Comments (7)

  1. Jason Harris repo owner

    Hi there,

    If you click the "Allow Push to Any Repository" checkbox does then you should be able to Push, etc. Can you confirm this?

    Can I also get you to enter the repository identity in the advanced options in the server configuration. You need to do this for SVN repositories. You can find the id by executing "hg identity --rev 0" on your local clone. After this push/pull should recognize the server.

    I'll write this up as a FAQ item within the next day or so...

    Thanks! Jas

  2. Jason Harris repo owner

    Thanks for getting back... but to clarify... What actually worked? Setting the repository key in the advanced options or using the allow push to any repository, or both?

    Thanks, Jas

  3. Tim Keating

    Selecting "allow pull from any repo" is what allowed me to do the pull.

    I was also unclear about something. This isn't actually a SVN repo I'm working against, it's just a working copy checked out from SVN that I also hg init-ed and cloned locally. So I'm pretty sure the setting the repository key isn't really an option in my case.

  4. Log in to comment