P3D3::Kaleidoscope not found

Issue #307 duplicate
Former user created an issue

When I select Kaleidoscope as my Diff Tool I receive a popup saying Kaleidoscope is not found.

Kaleidoscope is installed into /Applications. I have tried closing MacHg, opening Kaleidoscope, and re-opening MacHg. Same error.

Comments (5)

  1. Andrew Ellis

    Sorry, wasn't logged in when I reported this.

    I would also like to say that if I choose "Other" and type "ksdiff" into the text box that works. I assume if that works selecting Kaleidoscope should work as well.

  2. Jason Harris repo owner
    • changed status to open

    Sorry this is fixed in my development version but I still haven't released a new version yet with this fix. It was because the bundle identifier changed to com.blackpixel.kaleidoscope since the program changed companies...

    I haven't pushed these changes to the site since I tend to do a lot of history rewriting on the changes as they go which makes it kind of hard for others to follow. I'll push them this weekend though in an alpha...

    This will be fixed in the next release. Sorry.

    Cheers, Jason

  3. Log in to comment