UI does not refresh on Yosemite

Create issue
Issue #351 new
Michael Büning created an issue

I'm not sure what actually triggers it but when using MacHg 1.0.2 on a MacMini with MacOS X 10.10 Yosemite installed the application becomes unusable at some point: Views don't get refreshed when switching between them. Scroll views don't get updated on scrolling. Preference window does not display toolbar (see screenshot). It reacts to clicks though. The window traffic lights stay grey even if window is active. Resizing the window completely messes up the UI (see screenshot).

Comments (9)

  1. Michael Büning reporter

    The problem is the date representation in the history view (see attached system.log). In Preferences -> Appearance -> Date Format I used the "Absolute" option. If I change it to "Relative" everything is shiny.

  2. Alec Matthews

    I can't stress how annoying this is. The biggest issue I'm seeing is scrolling.. once you hit the end for the elastic scroll, the list goes blurry and the I have to use the arrow keys to go up and down through the files to get the correct text to display when the file is selected.

    I spent last weekend looking at other clients because this problem makes MacHG almost unusable!!!.

  3. Alec Matthews

    It appears this is not that common an issue, or i would expect way more people to be commenting on it. Does anyone have some suggestions to get around this?

  4. Alec Matthews

    Something else I have just noticed.. When the screen smears like I have reported, the "Diagnostics and Usage Messages" in the Console app, fills up with aobut 8 of these:

    17-Feb-2015 3:02:39.442 PM Python[20536]: com.apple.message.domain: com.apple.BSDServices.ScriptingLanguageUse com.apple.message.signature: python com.apple.message.summarize: YES SenderMachUUID: 1372F532-D543-30CD-A37B-D1C3B9ECA70F

    I have no idea if this is related or not, but the coincidence is pretty high.

    Please let me know if I can help fix this because the other HG clients are junk compared to this one.

  5. Michael Büning reporter

    @whiteatom: Have you tried setting Preferences -> Appearance -> Date Format to "Relative"? Works fine for me. Would be nice if this issue gets fixed though :)

  6. Alec Matthews

    No change.. but I did just discover that if I change to Tree view from the "panel" view the smearing isn't an issue. Not ideal, but works for now.

  7. Log in to comment