P1D4::mchg "Document could not be opened. Data is currupted.

Create issue
Issue #50 resolved
rvg created an issue

This is the third time I have not been able to open a saved .mchg doc after using it for 4 days. MacPro4,1 QuadCore 8-cores, Mac OS X 10.6.3 (10D573). Mac runs all the time. MacHg 0.9.5 The .mchg file is inspectable via PliistEditor and appears okay. Help.

Comments (8)

  1. Jason Harris repo owner
    1. Can you send me the document?
    2. Can you drag and drop the document onto MacHg?
    3. Does the MacHg document have the mac hg document icon?
    4. Is the document in the recent items?
    5. Can you create a new MacHg document and save that and open that one?
  2. Former user Account Deleted

    I had the same issue before. If you have any server paths you need to make sure the server is mounted before opening the file.

  3. Jason Harris repo owner
    • changed status to open

    Ahhh... Thanks, could you give me a fuller description? What kind of servers are we talking about here? SMB, servers, maybe something loaded by MacFuse, or just a plain old Bonjour server?

  4. rvg reporter

    (Reply via rv...@mac.com):

    This has been working all morning, but I have created "save as" versions as well that also work-- just in case it "goes bad" at some point.

    I have two repos on a `/Volumes/WalterDataDisk` -- apple 1tb built in disk (my home office machine) and I have two identical push/pull repos on a afs mount volume `/Volumes/Users/jeffries/Hg_repository` which is how I share with my student team. Afs is to a MacServer running 10.5 server at university. I have 9 mbit TWC cable Internet service.

    The bad file and all the new versions I created today are in the Recent Items folder

    Might the corruption happen if the afs mount is not present ? I did reboot three days ago for software update. I think I then worked over the weekend with out MacHg running. When I tried to do my check in and updating last night is when I found the corrupted file again. I had not mounted the afs disk.

    Harvey

  5. rvg reporter

    (Reply via rv...@mac.com):

    Jason: this is just a mount via `afp:jeffries@dawes.sph.unc.edu/Users/` That puts a `volume` in my /Volumes/.

    The other end is a MacServer running OS X Server 10.5.

    I had an anonymous commenter who said that they had the same problem and it was due to "servers not being mounted" before starting MacHg.

  6. Log in to comment