P2D?::Create New Repository no longer works

Create issue
Issue #54 resolved
David Mitchell created an issue

After upgrading to 0.9.6, making a new document and choosing "Create New Repository" doesn't do anything. Likewise, Add Local Repository from either the context or main menu doesn't work. Cloning a server repository seems to work fine.

Comments (14)

  1. Jason Harris repo owner

    Hi,

    First thanks for your report!

    However, things seem to be working fine for me. How many others are having this problem?

    Thanks, Jas

  2. David Mitchell reporter

    I tried restarting MacHg but same symptom persist - anything I can do to help diagnose?

  3. Gustavo Picón

    I just tried to reproduce this bug, but the local repo was created succesfully. Maybe this is a permission problem in the directory you're trying to use?

  4. David Mitchell reporter

    I don't think it is a permission problem, as I don't even get the opportunity to select a directory. When I click Create New Repository, literally nothing happens. Contrast this with when I click "Clone a Repository", which immediately brings up the appropriate sheet and away we go.

    Trying a few more things out, I have found that I can add a server repository and clone it locally with no problem. Now if I click "Configure" on the context menu for my server repository, I can configure the url etc as expected. However, if I click "Configure" on the context menu for the local clone, no sheet appears or anything.

  5. Jason Harris repo owner
    • changed status to open

    First DJ, I believe you that you are seeing this!

    Unfortunately I can't reproduce this. Next, do you know much about XCode / Cocoa? Can you set breakpoints etc so we can diagnose what is different about your system than others? If so can you set breakpoints in actions like

    - (void) openSheetForConfigureRepositoryRef:(SidebarNode*)node

    And see what happens when you trace this through. Failing that can anyone else reproduce this?

    Failing that can I get you to try quitting MacHg, moving aside your current /.hgrc and and rerunning MacHg. You are running MacHg on your local machine where you are the owner and everything write? Ie you are not running as some remote login, or network boot, or non-admin user or something.

    You are just running this as a normal plain old vanilla user in a normal standard way right?

  6. David Mitchell reporter

    Ok, here are my results:

    Cloned the MacHg repo, to build I had to explicitly set the search path for plugins in order to find the BWToolkit plugin. Once this was set up, builds I do myself work just fine.

    So I tried the official build again and it still has this problem.

    I tried moving my .hgrc out of the way and both builds continue to behave as they did before: my build works, official build doesn't.

    I am a plain old Admin account on my machine.

    So, that's a bit special.

    I downloaded 0.9.6 from the website again and tried that copy, and it works perfectly! Comparing this to the one that auto upgraded I see that the auto-upgraded app is 7.9Mb, whereas the download from the website is 19.1, as is my own build.

    Finally, I downloaded 0.9.5 from the website again and ran that. I did a check for updates and had it install 0.9.6, which created a 19.1Mb executable that works perfectly.

    This is a bit of a dead end - I guess the first update just didn't work properly, but kind of a miracle that the app executed at all.

  7. Jason Harris repo owner

    Really interesting history there! Thank you for taking the time to track this down in the detail you have.

    You wouldn't happen to have the buggy MacHg would you still lying around? If so could you zip it up and send it to me?

    Again thanks! I'll mark this as resolved for now, unless someone else can get this buggy behavior on updating...

  8. Jason Harris repo owner

    Weelll... It looks like the .py and .pyo files are stripped from the attached Mercurial copy. It also looks like the Frameworks were also stripped of headers files and other files which are non-release files.

    Perchance did you run some sort of trimming application over MacHg, something that is meant to remove superfluous language files, tighten nib's that sort of thing? If my guess is right (a *big* maybe) do you know which program this was?

    Thanks! Jas

  9. David Mitchell reporter

    Haha, that would be a huge fluke if I'd run some strip app and neglected to mention it. Sorry, no - I just did a vanilla update and it all seemed rosy until I tried using the updated version.

  10. Jason Harris repo owner

    Darn... Ohh well... I guess I will just wait to see if this ever comes up again!

    Thanks again, Jason!

  11. Log in to comment