1. Jeffrey Goettsch
  2. py-pushnotify
  3. Issues
Issue #14 resolved

Update requests dependency to `>=2.0`

Miks Kalniņš
created an issue

Currently pushnotify depends on requests==1.1.0, but latest version is 2.2.1 as of now.

This by itself doesn't cause any problems, but there are quite a lot other libraries that use requests>=2.0 and since pip doesn't handle conflicts well this poses a problem.

Glancing over http://docs.python-requests.org/en/latest/api/#migrating-to-2-x it looks to me that update would only require updating setup.py or at most very small amount of changes.

Comments (4)

  1. neetu jain

    i ran into installation problem because of this :- Installed /root/office/projects/event-notification/buzzenv/lib/python2.7/site-packages/buzz-0.1-py2.7.egg Processing dependencies for buzz==0.1 error: Installed distribution requests 2.3.0 conflicts with requirement requests==1.1.0

    ..the problem is pypi does not have the latest version. The version of pushnotify on pypi is old. Can you please release a new version with latest code ?

  2. Log in to comment